Random Packet Loss with RUT240 in Passthrough Mode

Hello, I’m having a weird issue with a RUT240 (latest firmware) running in passthrough mode. It appears that whenever there is not a continuous stream of traffic (UDP and/or TCP - not sure what the trigger is), that it’ll start dropping about 60% of ICMP packets, possibly other protocol traffic. It’s almost like some kind of energy saving kicks in and the cellular modem and/or LAN interface start sporadically dropping traffic until a continuous stream is detected…

I’m encountering this issue specifically when using the device as a backup internet connection for my Ubiquiti USG-Pro firewall (not sure whether this affects other firewalls/routers). I have a static public IP from the cellular provider, and the RUT is in passthrough mode so it assigns the public IP to the USG router’s WAN 2 interface (no issue with this). When the router is operating in failover mode and all traffic is going through the RUT240 then there’s no issue. When I have a laptop directly connected to the RUT240 there’s no issue. However, when I have the RUT240 connected to the USG router and the USG is not in failover mode (all traffic going through WAN 1) that’s when I see the issue both on inbound and outbound ICMP traffic. This is very problematic as the USG needs reliable outbound ICMP communication to determine whether or not the backup connection is more stable than the primary before failover, and we rely on inbound ICMP traffic via 3rd party service to alert us if a WAN service is degraded or down.

Note that I don’t see this behavior at all when using the Netgear LB1120 nor Netgear LM1200 cellular modems in the exact same setup.

The below 2 screenshots are from our 3rd party connection monitoring service called VoIP Spear.

In this first screenshot the router is in standard (not failover) mode the entire time. At 5:30pm I noticed that the connection was bad (heavy packet loss) so I started pinging the static public IP from a few difference sources, checked the device’s status via web and CLI and you can see that for the ~20 minutes I was running a bunch of tests and traffic through the device that the issue is all but gone, and then almost as soon as I stop all of the tests it starts heavily dropping ICMP traffic again.

In the second screenshot you can see the issue until about 6:30pm when I disconnected the primary (WAN 1) service and the router failed over to WAN 2 (RUT240). For forty minutes, while all network/internet traffic flows through the RUT240 there’s no issue with inbound/outbound ICMP traffic. And then at 7:10pm I reconnected WAN 1 service, router failsback to WAN 1, we see the issue resume.

Again, because this behavior is not observed at all with other cellular modems, it leads me to believe that there’s some kind of energy saving feature(s) on the RUT240 that causes it to drop ICMP (possibly other) traffic when there’s little to no activity/connections… Or some kind of bug causing this behavior.


Would it be possible for you to provide more details? It would be great to see any relevant excerpts from system logs, routing tables, ARP tables, iptables rules, or tcpdumps.

Please, keep in mind that this is a public forum. Hence, ensure that any sensitive information is redacted before sharing.

Also, it seems that this issue may be a bit more complex to investigate. Hence, if you have the opportunity to communicate with us directly or through your sales manager, I would strongly advise you do so. This would allow us to freely share files and potentially arrange remote sessions if it will be required later on.

Kind Regards,

Hello @AndzejJ, thank you for the quick reply. I must admit that I’m very new to RUTOS and OpenWRT. I’m happy to provide any information you’re looking for if you can guide me on how/where to find it. As you mentioned, with it being a public forum I’d prefer to PM any files that might contain sensitive data as it’s quite likely that I could miss redacting something.

For now I’ll try doing a bit more testing, and with other routers, see if it’s universal or isolated to just when the device is connected to UniFi routers in a non-active failover setup. Just wasn’t sure if you might know off-hand whether or not there’s any energy/power saving features that might be causing this which could be disabled.

Thank you.

Confirmed that the issue is also present on the Ubiquiti USG router in the same setup (RUT240 used as the backup/standby connection): when it’s not the active route there’s extremely high packet loss for both inbound and outbound ICMP traffic (possibly other protocols). And similar to what I found with the USG-Pro, when the backup connection (RUT240) becomes active/primary route there’s no issue (packet loss) at all.

I still plan to test the same with some other routers but it’s very odd that I have no issues with Netgear’s LB1120 and LM1200 modems in the same setup. The only difference I’ve noticed between the Netgears and the RUT240 is the Netgears use a /24 subnet for the virtual network they create when set to “Bridge” mode (which is equivalent to RUT’s “Passthrough” mode), whereas the RUT240 creates a /30 subnet for the virtual network (“mobile_bridge”). Is it possible to change this virtual subnet to /24 to see if this corrects the issue?

Thank you.


This is why I asked if you have the option to communicate with us directly, as this would allow us to share information securely. There’s also a ‘contact us’ form available here.

System logs can be found in System → Administration → Troubleshoot. You can view system logs from the browser, or download a full troubleshoot file that contains different logs and device configurations.

The following commands can be used from CLI to get other information:

# To see the routing table, you can use:
ip r show
route -n
# To see arp table:
ip neigh
arp -a
iptables -nvL
iptables -nvL | grep icmp
#tcp dump
opkg update
opkg install tcpdump
# run tcpdump on LAN and capture pings
tcpdump icmp -c 50
# run tcpdump on mobile interface
tcpdump -i wwan0 -n icmp -c 50
# to same tcpdump to file so that you can download it later. For example, using WinSCP to download and Wireshark to open
tcpdump -i wwan0 -n icmp -c 50 -w /tmp/capture.pcap
#mtr package that basically combines ping and traceroute.
opkg update
opkg install mtr

However, since you mentioned the network subnet assigned, then the first thing I would suggest is checking out a topic here where one of the users had a similar issue and worked together with our RnD to resolve it. He also provided a quite extensive explaination and the solution to his issue. Your issue is slightly different, but it may be worth checking the same things (arp and mobile script) that are discussed in the post. This may give you a few hints.

Kind Regards,

Thank you for the reply.

I actually have been following that other forum convo: “RUT240/241 - [major problem] Passthrough feature not cooperate correctly with Juniper & Huawei Routers”, but my understanding is that this issue disrupts all internet access, which isn’t what I’m experiencing. I also SSHd into the RUT240 and checked whether or not the same symptoms were there and didn’t find this. But I’ll admit that I’m very new to this product and software so I could be missing something.

I will work on getting the requested information and send to you via secure channel.

Can you also please share instructions on how to change the subnet mask for the “mob1s1a1” interface from the default /30 to /24 so I can see if this resolves the issue?

Thank you.

Hi @AndzejJ I have collected the requested diagnostics info. I’ve also submitted the contact form on the website and made sure to select the option for technical support, however I haven’t received an email back yet. I’m waiting for an email from yourself or another support agent that I’ll reply to with the requested diagnostics info. Feel free to email me directly and I’ll reply with the diagnostics info.

Thank you.

This topic was automatically closed after 15 days. New replies are no longer allowed.