Problem adding VLAN on RUTX11

We have various RUTX routers at different sites and run VLANs on most of them. This week we decided to add VLANs to this site with a RUTX11and because you need a newer firmware in order to run hybrid ports, we updated to the latest firmware first (7.05.4). This is currently the only site that runs that firmware.

I’ve followed the normal procedure, disabled all VLANs on a port, saved and then normally I’d add the new VLAN, but this time it says “Failed to create new configuration”, just like the RUTX devices used to do before I found out you have to have a free port without any VLANs before you can add a new one, only this time I do have a port without any and still I get the error.

Done the usual reboot etc procedures as well.

All the ports are in use though if that is of any help. I wonder if this firmware might have a bug on the RUTX11 model, or am I doing something wrong?

Thank you in advance.

I see now that there is a modem update available for the device. Could it be possible that it needs that one? Seems unlikely to me though. Current modem firmware is EG06ELAR04A04M4G


I tried doing the same and never had any issues.

If a normal reboot doesn’t work, kindly reflash the firmware to the device and configure it again.
You can do this by downloading the latest firmware found on the wiki page (07.05.4) - RUTX11 Firmware Downloads - Teltonika Networks Wiki

Then in the WebUI of the router, navigate to SystemFirmwareUpdate Firmware. Turn off the keep settings then upload the downloaded firmware and proceed.

After the update process is done, it would go back to its default settings, from there try to configure VLANs again.

Let me know the results :slight_smile:

Best regards,

Ooof, that’s easier said than done. The router is in another country, so we’d have to do it remotely, or wait until we’re back again. The obsolete modem firmware theory is implausible for sure?


I have the exact same problem, I can’t add vlans!
Did you find a solution?


No, not yet… The advice I was given would require me to travel onsite, which I’m unable to do at the moment. Would you be able to completely reset the device and test? Curious if it works or not.

I tested the reupload of the latest firmware with default settings and it worked. I had to reconfigure the router but now it’s working.


This topic was automatically closed after 15 days. New replies are no longer allowed.