OPKG packages installation - package is unknown

I’m trying to install ipref3 tool on my RUTX50 RUTX_R_00.07.06.3.
I run the commands:

  • opkg update
  • opkg install iperf3
    As a response I get Unknown package ‘iperf3’
    Does anyone know what am I doing wrong?

Best Regards,

Look here the issue and solution are the same.

Thanks. After running 1st command “opkg -e /etc/opkg/openwrt/distfeeds.conf update” I get downloading error:
"Downloading https://downloads.openwrt.org/releases/21.02.0/packages/arm_cortex-a7_neon-vfpv4/vuci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.0/packages/arm_cortex-a7_neon-vfpv4/vuci/Packages.gz
Collected errors:

  • opkg_download: Failed to download h{only_2_links_in_post}ttps://downloads.openwrt.org/releases/21.02.0/packages/arm_cortex-a7_neon-vfpv4/vuci/Packages.=.gz, wget returned 8."

“root@RUTX50:~# opkg -e /etc/opkg/openwrt/distfeeds.conf list | grep iperf3
iperf3 - 3.10.1-1 - Iperf is a modern alternative for measuring TCP and UDP bandwidth performance, allowing the tuning of various parameters and characteristics.
iperf3-ssl - 3.10.1-1 - Internet Protocol bandwidth measuring tool with iperf_auth support”

But finally instalation doesn’t work:
“root@RUTX50:~# # opkg -e /etc/opkg/openwrt/distfeeds.conf install iperf3
root@RUTX50:~# opkg install iperf3
Unknown package ‘iperf3’.”


I tested the issue myself and couldn’t recreate it. Could you please share the command line output after executing these commands:

opkg -e /etc/opkg/openwrt/distfeeds.conf update


opkg -e /etc/opkg/openwrt/distfeeds.conf install iperf3



It works now. Idk why it caused error before. Thank you!

This topic was automatically closed after 15 days. New replies are no longer allowed.