Open port on RutX12 won't work

I have switched to RutX12 recently, but when I open the needed ports it looks good on the device but the ports will not open! The applications won’t work and when checking if the ports are open they are not according to

Firmware: RUTX_R_00.07.04.5


Could you clarify if both SIMs are in use?
If so, could you try enabling load balancing in the Network → Failover menu? Make sure to select Load Balancing in the top-right corner:

If this does not help, I’ll ask you to navigate to Network → Interfaces → General, and take a screenshot of the mob1s1a1 and mob2s1a1 interfaces. Make sure to blur out the last two octets of the IP address like so:

Best regards,

Both sims active. Load balancing enabled

The settings for ports (traffic)

And the setting fot load balancing:

Both SIM cards use an IP addresses that are in CG-NAT (Carrier Grade NAT) range, which is between and This means that these addresses are not reachable over the public internet.
To reach the device, your main options are:

  • Contact your ISP to acquire a public IP address;

  • Use a VPN to reach your device;

  • Use RMS - our remote management system to reach the router and the devices behind it. More information can be found here: RMS - Teltonika Networks Wiki

Best regards,

I use zero tier In order to reach the device from outside. My problem is that I have francotype post base stamp-machine that needs to be able to connect to the outside in order to update the value. But it won’t work. Do you mean that this also goes through public ip-adress?

Just to clarify, is the machine in the LAN, or does it need to reach the LAN?
ZeroTier can allow access between different networks. If you need to reach the LAN of RUTX12 from the internet, I’m not sure if this is the best solution, as forwarding will need to be configured on one of the ZeroTier clients with a public IP address.

Best regards,

Now I have changed to public ip-adresses: (It is fast when you are business and can pay for service)

Still the same issue; the ports should be open but when checking they are closed!

The zerotier I can use to reach a server behind the router, but I need to open the ports for the communication to work.

To clarify: The francoptyp stamp-machine needs that port 8080 and port 443 is open on the router in order to work properly from inside the lan.

And I can’t make the port open up.

It seems like the rules were configured in Traffic Rules section. The created rules open ports to the router itself, rather than the network behind the router.
Please delete the created rules, then navigate to Network → Firewall → Port Forwards and create new rules for ports 8080 and 443. The port forward parameters should look like so:

Where Internal IP address is the LAN address of the device.
By default, this rule will apply to both SIMs, so you should be able to reach the device by entering and in your browser.

Best regards,

Still doesn’t work.

Could you clarify where there are 4 rules? Only 2 should be present - one for port 443, and another for 8080.

Not sure why that happened…

Changed now

But still same problem…

It seems like your LAN network is on network, are you sure that is the correct IP and is in the LAN zone?


The LAN dhcp server gives addresses -
The I static mapping och MAC
The router have lan-adress
One can easily ping between units on the lan.

The adresses are in zerotier connection, and only for those connected there, ie the router and the external laptops.

When I check which ports the router listen to through CLI 8080 is not open despite the “port forward” rule! And the problem is for units (ie Francotyp) to connect from inside the LAN to an external server! So port forward ought not no be the solution for this…

Before I switched to rutx12 we had Rut241 as failback, but since the speed is low we decided to switch. When I connect rut241 it works again! And it worked good with the “private” ip-adress we had previously. The francotyp can connect. So there is some bug in rutx12
Both units have the same firmware, both units have similar configurations (on all menus where both units have similar modules). Both units have the same kernel.

This topic was automatically closed after 15 days. New replies are no longer allowed.