NMEA data forwarding not working

Using a RutX11 with firmware RUTX_R_00.07.04.5 I set up NMEA forwarding to enable an Android device running ‘GNSS Master’ or Bricatta’s ‘GPS Tether Client’ to receive GPS data over the LAN.

I followed the instruction to set it up, enabled all three GPS systems, and forwarded the data to my Android device first on port 8500, then on 8080. The router’s web interface displays an accurate location map.

I setup the router to forward to my laptop, and ran Wireshark which didn’t detect any tcp data on port 8500 from the router’s ip address. So it looks like the NMEA forwarding isn’t working for some reason.

Is there anything I might have missed to get this working?



The NMEA forwarding simply forwards NMEA sentences to the host/server that you specify in the configuration. More information about GPS functionality on RUTX11 is available here.

For testing purposes, you can use any TCP server (for example, Hercules TCP server that you can download from here) on your PC and try forwarding NMEA sentences from the router to your server. Make sure you specify the correct IP address and port numbers. If the sentences do not arrive on your PC, try disabling the firewall on the PC for testing purposes.

If you do not have a server to send NMEA sentences to, you can utilize one of the supported GPS IoT platforms here.

It should be possible to use Traccar as well. You can find more information about Traccar on their webpage here.

Kind Regards

I’m running Linux on my laptop and Hercules isn’t compatible.

Traccar requires a public port, but as I’m on LTE and the ISP uses CGNAT, DDNS doesn’t work:

network_get_ipaddr Error: 1

I tried Navixy’s automatic setup for the Rut950 but that has stopped at "Registration is in progress’, probably for the same reason which rules out testing with a server on the Wan.

Since this is all running on a Lan, I used GNSS Master on my Android phone.

I set up GNSS Master as a TCP/IP receiver, using the router’s ip address on port 8500, and NMEA Forwarding is enabled on RutOS for GPGGA, GNGNS, and GAGGA to send NMEA data to port 8500 to the phone’s ip address ‘Contain connection’ is off.

GNSS Master status is ‘Not connected’ and the phone is not receiving any GPS data.

I ran the traffic log for 7 hours, searched the log and found SRC= multiple times, and DST= zero times.

This is the same result as I got by logging the network data with Wireshark - the RutX11 doesn’t appear to be sending NMEA data to the specified ip address and port.

I also did a factory reset in case any settings had been corrupted but it didn’t make any difference.

It seems the RutX11 is not sending any NMEA data.

Does anyone know which services to check?

Any ideas?

Well today I resumed investigations.

I put the device on my desktop, and attached the portable GPS antenna. It found its location and logged around 7 satellites which is an improvement on the 2 or 3 it used when attached to the Panorama antenna.

I’m connected by wifi and set up traffic logging again on the Lan - this remains completely blank.

I also tried to check for gpsd output on port 2947 by installing JOSM with the liveGPS plugin - that didn’t get any fix. Back to the RutOS webui and now there is no GPS data at all. Pressing ‘update location’ returns the error ‘There is no GPS data!’, although the antenna is connected and was working fine. I rechecked the physical connection which is tight.

Do I have a faulty unit?

After disabling NMEA forwarding, the device reported its location on the Map page, so it seems I cannot have both the management page and NMEA forwarding.

I’m able to see the NMEA data by running:

cat /dev/ttyUSB1

But I’m still unable to pick up the NMEA data over the Lan.


Apologies for the late reply.

You can use netcat on Linux instead of Hercules. Run netcat on port 8500 (or whatever is configured on the router):

nc -l -p 8500

Enable NMEA forwarding on the router:

Does netcat show any data? If not, make sure that Firewall is disabled on your PC for testing purposes.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.