MQTT Broker remote access not working


I am using my RUT 955 as a mqtt broker to access Modbus data.
I configured the Broker with remote access and enabled Data to server.

Everything runs well is I reach to broker from the LAN side or via VPN
With remote acces via the mobile connection the Broker is not responding
I have a DDNS adres.

I also run a MODBUS client in the LAN, I can reach the TCP MODBUS from remote, no issue.

It looks like a Frirewall issue but I tried it all, the sales agent cant answer this either

I even bought a new RUT 956 but it has the same issue…

Best regards



I’m a bit confused by your issue. Can you clarify a few things for me?

  • What do you mean by “connection to remote access to Broker is not responding”?
  • Is “Broker” referring to your RUT955 device?
  • How are you trying to reach it? Are you using HTTP(S) or another method?

Kind regards,

Thanks for your response!

i enabled the internal MQTT broker so the broker is running on the device it self (installed the Pack)
When I am connected to the router via LAN / WIFI / VPN I can access the broker with a client.
When I am approaching it from outside (via WAN or MOBISAT) I can not reach it, I get no response, I no response on PING

I tried this setup on a RUT240, RUT955 and RUT 956
I tried a different sim card / provider, all unsuccessful

it look like the port 1883 is blocked from outside.
I am trying to reach it via a MQTT client (port 1883).

I run a MODBUS TCP server in the LAN and enaabled a port forward on port 502. The Modbus TCP is running perfectly, I can reach it from WAN.


Dear Marijus,
I would appreciate your support, I clarified my case below

This topic was automatically closed after 15 days. New replies are no longer allowed.