MQTT Broker on RUTX50

I have linked Node-red to the router and that is working fine via port 1883.

IF I wanted to run this as an external MQTT Broker, I presume I need a static IP address SIM card?

Is there away to get around this?


Yes, you would need a SIM card with a static public IP address, but there is another option. You can use a DDNS service instead. Here is more information on it: link to the wiki page.

Kind regards,


Thanks for the info, I have used a DDNS before however will this work with EE SIM card as from my limited research I understand the The EE mobile network uses Carrier Grade NAT (CGNAT) resulting in a double NAT.

So from my testing even when I know my current IP address it doesn’t seem to be contactable, well for sure no ports are open whatsoever when checking.

I have the same issue with my NVR HikVision cctv that runs through a EE sim in Teltonikia unit, never been able to get that to work with DDNS…

However I’m no expert and I could be doing something wrong.


You’re correct. If you’re using CGNAT, DDNS or any similar service won’t function. You’ll require a SIM card with a static IP address.

Best regards,


Ah okey, that’s a shame as I use around 1TB of data a month there are no static IP for reasonable money that will support that.

On my ProRouter with same network I got it to work with a VPN, but guess Teltonika doesn’t have this option built in.

This seems to be the biggest limitations of SIM card routers.


If you’re considering using a VPN for your solution, our routers support that feature. You can configure multiple VPN services with them. Here’s more information: RUTX50 VPN Configuration Guide

Best regards,


Ah okey, when you said there was no other option I took you at that and wouldn’t have looked into the VPN option, so if that will work I can look into that setup.


This topic was automatically closed after 15 days. New replies are no longer allowed.