Loss of Up and Download speed RUTX50

On the 26th June between 12:00-16:00hr I lost considerable up and download speed (from 60-80Mbps to less the 10).

I didn’t change any of the settings or parameters of the router. The only thing I did around that time is adding a second sim but that didn’t work at all. I didn’t investigate why not. I just took it out. The first and default sim kept working however quickly after that I noticed the severe drop in speed.
I rolled back to an earlier backup from before that period but still the original speed has not been established. I have upgraded the FW to the latest version but still no change. Any idea where I should look?

Speed variations inherent in cellular broadband for many reasons. High traffic, maintenance, upgrades.
Check to see if the speed drops off at a certain time each day for example 6pm to 8pm when folks get home from work and after having a meal sit on the net playing catch up with their daily emails etc etc.

1 Like

All these I am familiar with. What I have tried to demonstrate with the graph I included that is is consistently lower (not incidental)! A consistent and 80% reduction of speed is NOT normal. There must be a reason for that besides the occasional/incidental speed loss. Futhermore it is very noticeable when using the internet (as in Netflix, video calls, etc).

It could be caused by your carrier throttling your connection. Perhaps they have “hotspot” or home internet plans available?
The drop in speed is not usually noticable right away, but rather after using the SIM in a router for a longer time.
There are not throughput drop issues registered for the latest firnware versions, so I dount the issue is device-related.

I had a long discussion with the provider. Strange enough if I put the sim in my iPhone the speed is high (higher then I ever achieved with the router 100-120Mbps!).
The moment I put it back in the router the netspeed.com is back low.
I have considered also the provider is throttling the traffic. I wonder if they connect the traffic to a set of equipment and Cell ID and they can put somehow a threshold on it… Is there a way with a gsmctl command to work around it?

In my NOS account I can see that the sim is used by the modem of the router. So they can see it!

@Daumantas `Can we do some deep-diving into the speed losses I endure? I want to find the root cause of this please!

@VilaLongitude9Degr off topic but what tool are you using to generate that speed test graph in your top post?

I am a heavy user of HomeAssistant. It’s an open home automation platform with a lot of IOT applications.

If it is indeed carrier throttling the connection, the only workaround know could be to change the TTL. This can be done by navigating to Network → Firewall → Custom Rules and pasting this line:

iptables -t mangle -I POSTROUTING -o qmimux0 -j TTL --ttl-set 65

If anyone is planning to use this rule on a different device than RUTX50, qmimux0 needs to be changed to the physical mobile interface on your device (e.g. wwan0).


Did this as instructed. I don’t see any change (yet). Does that potentially mean there is no throttling?

Any other firewall settings to be modified?

Without having your logs it’s hard to say what the issue could be (please do not post them publicly). TTL is only one of the ways operators can determine is the device is a modem or not, but they could also use an IMEI database, in which case not much can be done.
Perhaps you have a pre-paid/post-paid SIM from a different carrier to try? Sudden loss of speed (especially when reboots do not help) is a very good throttling indication.

Best regards,

Dear @Daumantas I am more then happy to send any log. Just tell me which one you like to see.

At the moment I am probably over 6000km away from the router and that will stay that way for the coming 6 weeks. One of the reasons I bought this router because I supposed to be able to manage it remotely (and it would catch the 5G network). For now I can’t do any physical changes to the router, only remotely. What I can tell you is that when I put the sim card in my iphone it gives very high speeds. I have tried to bring the second sim to live with another sim card but that didn’t work. I don’t know why. I didnt have the time to sort that one out.
One more thing. Some 5 weeks ago I lost my connection via RMS (device off-line, but it was still operational). I could figure out why but when I finally could open the webui locally the RMS connection in the router setting was set to OFF. I didn’t do that but I switched it back on and the RMS was back. Fine. However at that time I have tried remotely by SMS to reset the connection. But the SMS function totally fails. I can send ‘meaningless’ sms messages to the router and they are well received. However when I send a command nothing happens. No appearance in the inbox nor any response from the router. Nada!. I tried with and without password. Nothing. I left it. Again too much time to sort it out.

The next problem I seem to have now is that on one of the LAN ports I have a router connected (static IP address ) but it doesn’t connect at all. The IP address doesn’t appear in the scan and the extended router (again it was working perfectly before) doesn’t respond. No clue why.

But these things although not nice are manageable. The speed and response time are my biggest frustration. 60-80 before was great, this morning I woke up with 7.3… If I set an auto reboot on 10Mbps the router is rebooting constantly. I reduced it to 5 Mbps now but in fact it is nonsense. Not workable.

@Daumantas You gave up on me? I have asked where I can send the troubleshoot file but no replies anymore and I am still far away from a decent solution.



Since you have 3 seperate topics open, it’s quite hard to follow the activity. I have provided the instructions to lower the TTL (regarding the speed issue). As for RMS and other issues, logs cannot be provided here, hence, it is recommended that you reach out to your designated sales manager or the reseller from whom you acquired the device in question. They will be able to assist you in addressing this matter more effectively.

Best regards,

I tried that but that’s worthless… I am not going to waste time on them.

But fair enough lets focus on one thread.

1 Like