L2TP Issue on RUT956

Hi,

I posted the below some time ago, and have since purchased a replacement RUT956.

L2TP Issue on RUT950 - Teltonika Networks - Teltonika Community

I have configured the firewall, L2TP, and IPSec settings as advised, but I am not able to connect to the VPN at all so have gone backwards, since I could connect to the VPN and get to the WebGUI on the RUT950.

Any ideas what I may be missing? When I connect using Windows VPN it says ‘The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer’.

I have tried enabling MS-CHAP authentication on the adapter, disabling firewall, etc, which doesn’t seem to work. PPTP is not working either.

One strange thing I have noticed is that the static WAN IP reported on the router is different to when I do an IP lookup on Google, but it won’t work with either IP anyway, and the one showing on Google I can’t ping whereas the one showing on the Teltonika I can.





image


EDIT:

I have also tried using this article - L2TP over IPsec PC - Teltonika Networks Wiki (teltonika-networks.com)