Issues with Wireguard Peer

Dear Team,

I’m facing issues with RUT241 establishing a peer connection with my vpn provider thru wireguard.
Something is wrong and i’m not able to pass anything thru the tunnel, i believe the issue is DNS.

My config

Can someone tell me where im mistaking ?

Thanks in advance,

A few remarks:

  • Wireguard peer ch_prot: set Allowed IPs to +
  • Zones: set wireguard=>lan to Accept/Accept/Accept
  • DNS->General settings: disable Rebind protection and set Listen interfaces to lan

From a ssh or CLI console, execute the command “wg”. What is the output (hide sensitive fields) ?



Thanks for your input.

I’ve tried however same thing, here it goes the output.:

root@Teltonika-RUT241:~# wg
interface: ch_prot
public key: key
private key: (hidden)
listening port: 51820

peer: peer
preshared key: (hidden)
endpoint: 14x.x.x.x:51820
allowed ips:,
transfer: 0 B received, 12.29 KiB sent
persistent keepalive: every 20 seconds
root@Teltonika-RUT241:~# nslookup
;; connection timed out; no servers could be reached

any other possibility ?

Thanks in advance,

Could you execute a tcpdump:

tcpdump -i any -n -v 'port 51820'

You shoud see outgoing frames, but do you see something coming back in ?
For testing, restrict Allowed Ips to one known value only and try to ping it ( will do).

Hi Flebourse

I’ve tried however the tcpdump doesnt give any clue. The packet goes out but doesnt return. I’ve configured with another vpn server and same thing.

I was reading another thread and another user passed thru the same. At this point i guess the issue is with teltonika firmware, unless someone made it work.

The headache to use wireguard doesnt worth, i will keep with openvpn.

ps.: ive tried the same config with pfsense and works without issues.

Thanks a lot for your help brother and im sorry for bother you.

1 Like

Have you checked the keys ?


Yes… im using the same configs on pfsense and its working.
Something is wrong at teltonika router, i suppose.
By the numbers of threads around internet about the same. its a pity. i really like teltonika

1 Like

I am facing the same issue, been fiddling with this for a month now nothing has worked, i really think this is on the teltonika side, and i really hope they will fix this issue soon, i have rutx50, and i cannot connect to any ports everything is closed if i try portscanner i am using mobile internet not using wan.

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.