Internet access via RUTX11

I have a RUTX11 installed on my sailing vessel. We access the internet via a mobile data sim for TV, laptop, phone etc. Initially it was fine with no internet access problems, however, we cannot access the internet from some (not all) devices. When trying to access the internet, the device is ‘seeing’ our wifi in available networks, but instead of the padlock icon (presumably indicating password required) there is a ‘X’. When asking it to connect, there is a box telling me to ‘Enter the Network Security Key’ with a note indicating ‘Some information changed since the last time you connected. We need additional information to complete the connection’. Please can you tell me what I need to do to correct this, bearing in mind that I have only very basic skills.

Hi John,
if you didn’t change the PSK (aka security key) the cipher type may have changed.
What happens if you enter the PSK again?

Try to “forget” the wireless network on the affected devices and reconnect.

Your encryption type should be WPA2-PSK and your cipher should be CCMP.
Are the affected devices very old? Then you might try to switch back to
WPA-PSK/WPA2-PSK and the Cipher to TKIP+CCMP in the wireless interface
configuration.

Hope that helps. Regards,
Timlapse Admin

Hi, Thank you for your reply. The security key hasn’t been changed and if I enter it again it still won’t connect. The devices in question aren’t old (probably 3yrs old max) but I did try to change to WPA-PSK/WPA2-PSK and cipher to TKIP+CCMP. I also tried WPA-PSK and cipher CCMP, Now I can’t access the internet at all (currently using external wifi). Any other idea on what to do to get the problem sorted?
Thanks
John

UPDATE
Hi, I’ve managed to get connection using WPA2-PSK CCMP, but the one device (my laptop) that was able to access the internet without problems now seems unstable ie the signal keeps dropping out. I’m hoping it will settle down but if you have any suggestions, I’d be most grateful.
Thanks,
John

Hello,

Three years in production is a long time, and the device may have experienced natural wear, especially if it has been used on a sailing vessel. Could you check if there is any mechanical damage or corrosion inside the chassis?

Best regards,

On the WiFi clients giving you problems, try ‘forgetting’ the SSID and then try establishing a new connection.

Hi, the device I was referring to being max 3 yrs old wasn’t the router, it was the laptops and phones. The router was only installed earlier this year.

Hi Mike,

I presume you mean ‘forgetting the SSID’ from my laptop rather than within the router? If so then I have tried this but the wifi is still constantly dropping out. I’ve got a stable signal on the other phones/laptops now after changing to WAP2PSK CCMP but the one device that was previously stable (before the change) is now the one not holding the signal - odd!

Hi John … yes I did mean the laptop … it was worth a try as I’ve been able to ‘clear’ issues in the past using the ‘forget’ on windows based clients. Alas, it seems it hasn’t brought you to a happy conclusion. It is weird though.

Hello,

This could be a Wi-Fi channel congestion issue. Have you tried scanning your wireless channels to see what the situation is? If not, you can do this by going to Status > Wireless > Channel Analysis. Scan the channels to check if your currently selected channel has many other APs (Access Points) operating at the same frequency. If it does, try changing to a different channel further away from it by going to Network > Wireless > Radio.

2024-06-11

Best regards,