Guest Wi-Fi with RUTX_R_00.07.07.1

I’m following the configuration guides (this How to set up a guest WiFi network on RUTX - Teltonika Networks Wiki and this How to set up a guest WiFi network - Teltonika Networks Wiki) to create a guest network but am unable to get it working. There seems to be something wrong with the LAN interface physical settings. Type: Wifi isn’t selectable anywhere?
After some tinkering I got two results - either guests get to access my entire LAN or nothing works.

First ensure the device’s firmware is on the latest version.

Then, my first guess is that your Guest VLAN is allowing forwarding to your LAN. So in the first set of instructions that you mention …

Ensure that the only zone showing in your ‘Guest’ zone > Inter-zone Forwarding is the WAN. If others are present, remove them. Sometimes, depending on the order of steps you’ve gone through to configure, the LAN gets added, you don’t want this in your instance.

Also, ensure the default zone behaviour for ‘Forward’ is set to Reject

And lastly, ensure that the only thing in your ‘Covered Networks’ is the Guest network, if others are present, remove them.


You can also create Hotspot for your guests.
It has even multiple different templates, which is accessible from the Package Manager such as airport theme, office theme, bus theme, etc,…

You can find detailed information from here

Please let me know about the updates!

Kind Regards,

Nah, I think the problem runs deeper than missing firewall rules.
After a factory reset, I tried to replicate what I did, with screen shots in a document I can’t attach. At first following the guide procedure everything was green and running but no clients could get ip-addresses., After the documented process I tried to mess around with the interface physical settings. the network is now down with the message “Error: * Network device is not present”. Now it is up again, but clients still can’t get an Ip-address from it.

Realized I can paste images here instead…
SSID config:

Isolate clients:
Wireless security:

No other changes. Here I click “Save & Apply”.
Set up IPv4:

Disable IPv6:

Assigns firewall zone: guestzone (pre-existing from old config?)
Save & Apply.

New interface comes up and looks operational. Clients cannot get an IP-adress.

Pre-existing firewall config:

Disable IPv6:

My android connects but cannot get an IP-address and disconnects.


I’ve created the same configuration that you’ve just done and my phone successfully connected and not disconnected after a while.

I also attached the screenshot below.

Can you please share the screenshot for the DHCP leases section on the WebUI?
You can access it via, Status > Network > LAN


I discovered the problem. I don’t want the DNS to listen to requests from WAN so I configured a listening interface on the DNS. Appearantly it affects DHCP as well. I changed the config and now everything works. Sorry guys, and thanks for your efforts!

I discovered that if you configure the firewall rule like this,

you actually get the desired effect! Guests can trafic the web, but cannot contact internal devices. You no longer need the additional firewall rule that prevents just 22,80 and 443 from being targeted.


I’m glad the issue is resolved!


This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.