FW RUTX_R_00.07.06.3 Could not install PIP


I noticed when I was setting up a RUTX12 to run some python scripts that after I updated to the latest firmware (RUTX_R_00.07.06.3) I could not download pip for python.

After installing python3 from the package manager I tried running the command in the CLI:
opkg install python3-pip
Only to get the error: Unknown package ‘python3-pip’
I did a opkg update and tried again but got the same error. When running opkg list and looking through the list sure enough I could not find pip there.
The strange thing is that I have a RUTX14 and there I could install pip without problems. I checked the firmware version and it was RUTX_R_00.07.05.3 so I downgraded the RUTX12 to the same firmware version and could download pip without problem.

I’m quite new to this environment and using openwrt but have I missed something? Is pip not suppose to be available on RUTX_R_00.07.06.3?

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.