Fw 7.05 breaks lan config

Just updated a remote TRB140 from 7.04.5 to 7.05 and now the lan port is failing, very strange but the device is not accesible over the lan port, no ping. Web config network/lan hangs.

Tried a local rut300 with same upgrade and same result, well the lan port is working but the web config network/lan/edit also hangs. Restore default settings doesn’t help.

I now have a problem of a disfunctional remote TRB140 in production, call me stupid. Reset will break and I’m scared to edit /etc/config/network. No local TRB 140 available either.

config interface ‘lan’
option proto ‘static’
option ipaddr ‘’
option netmask ‘’
list dns ‘’
option ifname ‘eth0’
option metric ‘1’
option disabled ‘0’

upgraded to 7.05:
config interface ‘lan’
option proto ‘static’
option ipaddr ‘’
option netmask ‘’
list dns ‘’
option metric ‘1’
option disabled ‘0’
option device ‘eth0’
option _area_type ‘lan’

Can’t see anything wrong but for sure it doesn’t work.

What are my options? Firmware downgrade an option withour loosing connectivity?


This is an odd issue as there were no such complaints so far.

Could you try using a different LAN port / reinsert the cable / power cycle the device?

Also, could you please try the bootloader procedure on your RUT300 to see if the issue persists? Bootloader instructions are available here (upload firmware to

Kind Regards,

Thx, just tried @rut300.

After the upgrade test I’ve already tested a downgrade to 7.4.5 and indeed settings were reset. Now I’ve upgraded again and, sure, lan config is working again, so can’t reproduce any more #rut300 :frowning:

Meanwhile @remote TRB140 I had removed the lan interface and was no longer able to create one due to a hanging webui. But now I somehow could create a lan again without hanging the webui! It seems correct now only still no comms @lan port:

ping from trb140 to lan jetway
jetway$ tshark -f “arp”
1 0.000000000 Teltonik_31:e7:66 → Broadcast ARP 60 Who has Tell
2 0.000060627 JetwayIn_09:1b:73 → Teltonik_31:e7:66 ARP 42 is at 00:30:18:09:1b:73
3 1.016171932 Teltonik_31:e7:66 → Broadcast ARP 60 Who has Tell
4 1.016232391 JetwayIn_09:1b:73 → Teltonik_31:e7:66 ARP 42 is at 00:30:18:09:1b:73
5 2.056209616 Teltonik_31:e7:66 → Broadcast ARP 60 Who has Tell
6 2.056270027 JetwayIn_09:1b:73 → Teltonik_31:e7:66 ARP 42 is at 00:30:18:09:1b:73

but @trb140
ip n: dev eth0 FAILED

hmm, time for a reboot? Do I dare? I guess there is no way to power cycle remotely (rfe). You pay my flight to the Seychellen :slight_smile: ? I’ll ask the site first and let you know.


Short update. What happened. After the fw update with keep settings the device returned correctly after the reboot. I could login at the lan port and see the new UI but very short after that, a few seconds, the connection was disconnected. The lan port was not reachable any more but I could access the device over the mobile connection. See description above for the rest of the story.

All seems to be working except for the lan port. It does send but does not seem to receive. When the port is enabled it will be alive (= pingable) for ca. 4 sec, stops working but then also disturbs comms of other devices connected to the same switch: no/slow ping, loosing connections! Therefore the lan port had to be disabled (mission critical stuff).

While update and lan port issue happened at the same time a hardware issue between lan port and switch or switch could not be ruled out either just a bit unlikely/unlucky? Atm I’ve no idea what’s going on overthere. Can’t explain the disturbance of the other devices. Duplicate mac addresses, loops, hw issues? Difficult to say.

Next steps is to check cabling & switch and power cycle the whole thing. Not easy being remote and on a running complex system that needs uptime. Ideas for diagnosing this welcome! tbc.


It is possible that you had some specific configuration that caused the issue when you updated to the latest with keep settings. I am afraid that you’ll have to reset the device (or downgrade → reset → upgrade). Also, given the ARP issue, can you, or someone on-site, try unplugging and then re-inserting the LAN cable? Maybe this will help.

Kind Regards,

The webUI issues seems to be my brainddead browser, firefox does the job. One down.

Scheduling for a reboot/un/re-plug session, that will take time.

Reset device is impossible remotely without a working lan… need to send a new, configured device, good for you less for me. Or is using rms an option? I can’t bring up my vpn after a reset but maybe rms is activated after a reset? ah pin code… bummer.

Could you check this “lan” config (uci show…)? Some new options but without documentation of last fw I don’t know if something is wrong, lan.disabled is to prevent disasters.








Have you tried clearing cache on your browser?

By default, RMS is enabled on the device, so if the device has internet connectivity and can reach RMS, it should connect to it after a factory reset. Also, it is possible to use SMS commands to configure most of the settings on the device. If you have SIM card inserted in TRB140, can you check with uci show simcard | grep pin if PIN is configured? For example, if it returns simcard.@sim[0].pincode='1111' , then you should be able to set a PIN with the following SMS:

#admin01 is your password. Notice that there are no apostrophes when using UCI with SMS
admin01 uci set simcard.@sim[0].pincode=1111

As for the UCI show, right now I do not have a TRB to check, and the output can be slightly different depending on the device. I will check it tomorrow and let you know.

Kind Regards,


Un/re-plugging, rebooting TRB40 & switch didn’t work. So it’s seems a config upgrade problem or a hardware issue,

Ok, we try the rms route, I’ve also read the sim pin should surive the factory reset. Hopefully the free 30 days still work.

But we also going to order a new trb140 config, test and send it to the site.

But this will be started not before wk 44. We can live without a lan port for the moment.

thx for the help so far, appreciated

This topic was automatically closed after 15 days. New replies are no longer allowed.