Force-send DHCP option 43 in hotspot with RUTX12


I’ve been researching a while now but can’t figure out how to force-send DHCP option 43 to all clients when hotspot is enabled on RUTX12. I’m using RUTX_R_00.07.03.3 and can’t use Hotspot 2.0 because I can’t use a secure WIFI with password, so I’m stuck with the regular Hotspot functionality.

What I’ve found out so far:

  • setting the DHCP option 43 in a “normal” network is simple but this won’t affect hotspot
  • “Hotspot” is apparently a coova chilli captive portal which uses it’s own DHCP server and can’t be combined with a network interface.
  • coova chilli apparently supports DHCP options but those need to be activated as a compiler argument (coova dhcp option 43 · Issue #193 · coova/coova-chilli · GitHub) and there is no mention of this in the normal coova chilli config docs.

Anyone have a suggestion?

Thanx for sharing this. Although having done no more new hotspot systems for a while, this is very interesting for me. Have used coova-chilli very extensively, but not with this option. However, always done hotspots (incl. mobile) using official openwrt devices, which are much more appropriate for this purpose compared to teltonika or mikrotik, because being completely open source. Thus, allowing compilation of coova with special options.

Which opwenwrt devices have you used? I’m open for suggestions, but so far I’m quite satisfied with value-for-money of the RUTX12 devices. They do have quite a lot of customization options and the new remote management system is also quite helpful (now managing more than 100 mobile devices)

Sorry to say, but I can not post here refs to other suppliers devices. However, in case you really need 2 SIMs, your alternatives are limited, indeed.

This topic was automatically closed after 15 days. New replies are no longer allowed.