Firmware 7.6.8 pulled

According to Global RUTOS changelog - Teltonika Networks Wiki

Firmware R_00.07.06.8 was removed due to an issue with inefficient memory allocation for LED control.

What should be done to devices already updated to this version? Is it ok to run? Will it damage the device? Should we roll back to 7.6.6? Some guidance would be appreciated.

Well, I tried to downgrade an X11 to 7.6.6 but it failed

download complete, verifying image
Tue Apr  2 19:26:47 EDT 2024 upgrade: Downgrade is not allowed
Image check failed.
invalid image, aborting

So I guess I have to wait for 7.7… or?

Just stop ledman:

/etc/init.d/ledman stop

What are the side effects of doing that? Sorry if this is a dumb question.

No fancy leds blinking and so on. You can also execute a /etc/init.d/ledman disable to be sure it won’t come back after a reboot.

Thanks. I ran the following via RMS Task

/etc/init.d/ledman stop ; /etc/init.d/ledman disable

All LEDs are dark on the unit. Looks strange but still works. Hope this is fixed soon, strange bug. I still don’t understand what happens if we don’t disable this. The system eventually crashes due to lack of free memory? Something worse?

Yes, there is a severe memory leak.


Firmware downgrade should still work properly to previous 07.06.x versions, could you clarify how you were downgrading the firmware?
If LED operation is not crucial to your device, then the solution provided by flebourse is the easiest one, and should get rid of the memory leak.
Rest assured, we are working as fast as we can to release the firmware with this issue fixed, and it should come out soon.

Best regards,

I was trying to do it via ssh

# sysupgrade -v /tmp/firmware.img
Wed Apr  3 00:35:01 EDT 2024 upgrade: Downgrade is not allowed
Image check failed.

But, via GUI also fails

I have the offending firmware installed on my RUTX50 router, if i run the following command to temporarily fix the issue, not that i have noticed an issue myself: “/etc/init.d/ledman stop ; /etc/init.d/ledman disable”.

What will happen when the next firmware is applied?

Will the next firmware auto enable the service, or will i have to run a command similar to: " /etc/init.d/ledman enable ; /etc/init.d/ledman start" to re-enable and start the service?

If the memory leak is a security issue and or damaging the device, i will apply the temp fix asap! or should i wait a few days perhaps for the next firmware release?

@akwe-xavante I’ve downgraded my firmware to RUTX_R_00.07.06.6 You can download it from here… Once you downloaded the RUTX_R_00.07.06.6 Firmware, just drag and drop as in the picture if you want to downgrade. I’ve had no issues and everything is working fine.

Depends if you upgrade with keep settings set. If so you’ll have to re-enable the service.

New firmware now available addressing the issue.

This topic was automatically closed after 15 days. New replies are no longer allowed.