FCB toggle test problems

I followed the instructions for M-bus. I’m testing with the FCB toggle “on”, it reads some of the data, you see in the picture.

When FCB toggle is “off” , it reads all the data but, when I test again, it does not read the data. I change the FCB toggle “on” position again, it reads all the data. When I save and try again, it does not read data again, I think this cycle will continue forever. What could be the reason?

best regards

I have exactly the same problem.

I hope there will bei a solution.

I hope someone knows the problem. I don’t want to buy a different gateway.

Have you already tried whether a factory reset helps?

Yes, I’ve tried.

What brand meter are you using? I cant read the text in the images?

I have the same problem with a Garo (rebranded Carlo Gavazzi).

It seems that after the first reply from the meter (replies with 3 frames) all subsequent responses are the values from the third frame which are values of negative transfer (eg solar production or simiar). These values will always be 0 in a normal installation.

Is it possible to cat the live response in terminal?

According to the manual one should program it with the first request (VIF/VIFE values) but I cannot get this to work either,

I also use Carlo Gavazzi EM340 M-bus.
Maybe the problem is Carlo. I will buy a different brand M-bus analyzer.

A bit hard to search for info on this.

Beckhoff automation seem to handla Gavazzi meters with some extra flags.

They reinitialize the meter every time they request data to get full readout every time. Seems a bit non standard.

Any info on how to use the mbus-serial- commands from terminal? Im struggling to find which device to use to test.

Has nobody an idea?

I sent 4 e-mails to Gavazzi and they didn’t respond. Teltonika said, we will check. I ordered an energy analyzer 7KT1667 from Siemens. I will try it, if again same problem then I will change Teltonika.

This topic was automatically closed after 15 days. New replies are no longer allowed.