Failed to edit configuration on rutos for zerotier

Hello, I have the following:
RUTX50 with just installed Zerotier, RutOS 7.06.10.

I add a new instance, then I add a new network configuration. When I try to save it terminates with error “Failed to edit configuration” and it saves it without the network ID.
If I go through cli and manually edit the zerotier config file in /etc/config and manually add option network_id ‘my network id’ and save it, it appears in the UI and node joins the network.
But if I try to edit IT via GUI and then try to save it, even without modifications, it says again failed to edit configuration.
I tried to give more extensive permissions to the config file, but no change.

Now I have to enable LAN bridging and I cannot proceed.
Anyone can help ?


Could you please share screenshots of the configurations for ZeroTier from WebUI?

Best Regards,

Last screenshot occurs afted clicking Save&Apply on 3rd screenshot (the network ID details)
The window closes but no updates are retained (the network ID is there because i manually edited the config file)

On another RUTX50 device, same firmware, this does not occur, but the device connects to the network but is not possibile to ping in each direction (while other nodes are pingable).
ZeroTier was of course in both devices installed from the repository,

Only particular thing is that the device that presents this problem on the LAN address, due to a requirement of some appliances, is managing the network, which is normally “public” and not private, But I cannot change this configuration.
OpenVPN is running on the device and there are no issues.

In order to use don’t you need to enable “Allow global IP”?


Client Configuration | ZeroTier Documentation

Even doing that, it does not let me to save and terminates with error. It seems more a UI issue, because when I edit the config file manually it connects ok and ping works.
Nevertheless I could also go on and complete the config manually (i need to bridge the LAN), but I do not know what other modifications to the ROutOS it does when you enable LAN bridging (i.e. firewall rules and network config)


In this situation, I recommend you complete a factory reset. If you don’t want to lose your configurations, don’t forget to download a backup file of your RUTX50.

It should solve this issue. Please try completing that and let me know how it goes!

Best Regards,

Hello Marija,
since the device is remote we will have to go onsite to do that.
In the meantime we managed to do the config manually via CLI, but we need to know how to persist the bridge between br_lan and the zerotier interface. In which file the bridge configuration is saved ?

We found it in /etc/config/network.

It’s great to hear that you’ve located the necessary directory and are able to configure Zerotier via CLI. Do you require assistance with anything else?

Best Regards,

We are ok for now, thank you very much!

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.