Double NAT with TRB143 modem to Synology RT2600ac router

I’d like advice on how to configure the TRB143 (and RT2600ac) so that it bridges the Vodafone mobile WAN (dynamic IP address) into the router with no NAT.

I’ve tried changing the WAN mode on the TRB143 from NAT to both Bridge and Passthrough (with various combinations of associated settings) but to no avail.

The current RT2600ac Primary Internet settings are:
Connection Type: Manual
IP Address:
Subnet Mask:
Set as default gateway: Enabled

the RT2600ac Local Network settings are:
IP Address:
Subnet Mask:
DHCP Server: Enabled
Primary DNS:

The TRB143 WAN settings are:
Name: mob1s1a1
Protocol: Mobile
Mode: NAT

The TRB143 LAN settings are:
Name: lan
Protocol: Static
IPv4 Address:
IPv4 Netmask:
DHCP Server: Off

I’m afraid that networking isn’t my strong point, and I’ve so far failed to find any appropriate advice on the internet.

Many thanks.


To determine where the issues lie, I recommend testing the setup with only a single bridge at a time. This will help isolate any problems in each router separately.

Have you been able to successfully set up bridge mode on the Teltonika router by itself?

Kind regards,


Hi Marijus,

In the testing I’ve done on the Teltonika I’ve never managed to get it to present the WAN Address to either the router or to my computer when connected directly to that.

There are various settings that I’m guessing I don’t know enough about, or that are confusing. For instance, in the manual it says on the WAN page ( that Disable DHCP “Disables dynamic allocation of client addresses when toggled off” and that the default is ON. But the default (at factory reset) is actually OFF, and this is confusing anyway – what does it actually mean? Does Disable DHCP mean that it’s disabled when it’s ON, or that DHCP is enabled when it’s ON? When it’s set to ON, the options to add a MAC address and lease time disappear.

It’s odd that there are no instructions available for using a TRB1xx simply as an LTE modem that can be plugged into the WAN port of a router. It’s clearly a very capable device and all of the configuration examples that I can find are for far more complex applications.

Many thanks for your time.



Setting the WAN interface to Bridge mode should be straightforward. Just follow these steps:

  1. Navigate to Network → WAN and click “edit” on your desired interface.

  2. Under mode, select “Bridge” and then click “Save & Apply”.

  1. After this configuration, you should no longer be able to reach the router via Instead, your WAN address should be bridged to LAN ports.

Kind regards,


Hi Marijus,

How should I configure the LAN of the computer that that I connect to the TRB143? I’m able to connect if I manually assign TCP/IP settings (as per my original scheme) but using DHCP assigns an address in the 169.254.x.x range, indicating that there’s a problem. I see no way to configure the computer’s LAN port that will accept the (dynamically assigned) WAN address from the ISP. Is there no need to assign (on the TRB143) the MAC address of the target LAN port as suggested in the online manual?

I realise that if I had an ISP that assigned a static IP address, the process might be simpler, but unfortunately I don’t.

Kind regards


I’ve been doing further research on this, and it seems that CGNAT offered by a consumer Vodafone/Voxi contract is never going to provide the functionality that I require:

“A standard mobile network SIM card will use CGNAT (Carrier Grade NAT) and will only allocate your 3G or 4G connection with a PRIVATE IP Address on the mobile networks private network. This means you will not be able to connect to your 3G/4G router which of course means that things like Dynamic DNS will not work, neither will router functions like port forwarding.”
From Fixed IP SIM Cards | 4G Router Store

Nonetheless, I’d still like to see Teltonika provide basic Bridge/Passthrough config instructions for connecting a TRB1xx to the WAN port of a router.

This topic was automatically closed after 15 days. New replies are no longer allowed.