Devices seen as offline on RMS although they are really online


I have several Jetsons deployed on field connected to RUT956.
Most of the RUT956 work correctly, but I keep having the same problem with two of them :
I have installed on the Jetsons, which let me sees if they are online or not and connect to them by SSH remotely. The thing is, I see the two jetson online on but not their RUT956 on RMS.
As I’m able to connect by SSH to the Jetson, then to the RUT956 from the Jetson thank to, I have seen two things that are weird :
For one of the faulty RUT956, let’s call it R1, the file /etc/config/rms_mqtt contains this :

58 10 * * 1 /sbin/rut_fota -i >/dev/null 2>&1 #746c74

And for the other one, let’s call it R2, the /etc/config/rms_mqtt file does not exists at all.

What I tried for both of them was this:

opkg update
opkg install sudo
opkg install nano
sudo nano /etc/config/rms_mqtt

and then I pasted the content of a rms_mqtt file of one of my working RUT956.

I removed then readded the two faulty devices on RMS, then did this on both :

/etc/init.d/rms_mqtt restart

Then I saw both of my device back online again on RMS.
The thing is it worked for both of the RUT956 for a while, but after like three weeks I had the same problem on the R2 device.
I’m not able anymore to create and write inside the rms_mqtt file: when I try to save the file with nano, I have the message:

[ Error writing rms_mqtt: No error information ]

Does anyone has an idea of why I encounter this problem of RMS seen offline after a while, although they are in fact online ?
I precise that I run a Python program on the RUT956 constantly (with while True loop) at the RUT956 startup. Could it be a problem ?
I have made a post in the past about the problem, and found out how it could be fixed, but I would like to avoid the problem now. Link of the post : RUT956 Online but not connected to RMS Website - #4 by LucasFicha

Thank you in advance for your help and answer,


As this topic is closing tomorrow, could I have any help please ?

Thanks in advance,


@LucasFicha Sorry if it’s just a “me too” post, but I have had the exact same thing happen to several of my devices. It usually happens after a WAN failover event. I had two support cases open about it but they were closed with no concrete finding.

The ticket #s were

  • 281779
  • 291677

… in case you or Teltonika want to cross reference the notes.

I suggest you open a support case- maybe somehow we can figure out the common triggers that lead to this (rare?) event.

@luckman212 Thank you for your answer, I will open a support case, thanks.


Apologies for a late reply.

Firstly, what firmware version is installed on the devices?

Are you sure the first R1 has those lines in /etc/config/rms_mqtt ? Those lines look like from crontab. If those lines are indeed there, I would suggest restoring the device to factory defaults, or even better, performing the bootloader procedure to reflash the firmware completely. Bootloader instructions are available here.

What about RAM / Flash usage on your device? Perhaps it would be possible to monitor it?

Also, would it be possible to test the devices without your python script?

Kind Regards,

Hello @AndzejJ
Thank you for your answer.
The firmware is the latest available, the RUT9M_R_00.07.04.5
The R1 had indeed thoses lines.
The problem is that my R1 and R2 are deployed on field, so i’m not able to reflash them, or maybe I could do it remotely ?
For the Flash usage, there should be enough storage as I use a 32Go usb stick as memory expansion on both of the RUT956.

Kind Regards,



The rms_mqtt config file should contain configurations for RMS connectivity, such as port numbers, IP addresses, paths to certificate files, etc. So in your case it is odd that crontab entries appear in that file. How many devices do you have and how many are affected? Do you run python scripts on all of your devices?

The latest firmware version for RUT956 is v7.05.4 currently. When you updated the devices to v7.04.5, did you update with ‘keep settings’ option?

If the routers are in a remote location and are working for now, I would suggest that you avoid restoring/flashing them. But when when it will be possible, I would suggest that you reflash them and update to the latest firmware without settings, and then reconfigure them manually.

Could you please provide a bit more info about the script that you are running? Do you put the script into custom scripts in the WebUI?

Also, when the issue is present, could you please access the CLI and share the output of the ’ df ’ command?

Kind Regards,


I currently have 13 devices, all running the Python script. I have one device that is currently affected, and I managed to fix another one in the past. I didnt update with the “keep settings” option.
The script that i’m running is launched with the /etc/rc.local file. It runs a while true loop to open and close the relay pin if our device connected to the RUT956 is not found on the local network of the RUT956 using nmap command.
I have not put the script into custom scripts in the WebUI.

Here is the content of the output of the command df -h:

root@RUT956:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                10.5M     10.5M         0 100% /rom
tmpfs                    61.1M    184.0K     60.9M   0% /tmp
/dev/sda1                28.8G    138.9M     27.2G   0% /overlay
overlayfs:/overlay       28.8G    138.9M     27.2G   0% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock7          576.0K    292.0K    284.0K  51% /log
/dev/mtdblock6            3.1M      1.8M      1.2M  60% /rwm

Kind Regards,



In case if other devices work fine with this script, its hard to say what can be the issue here. I would suggest reflashing the firmware via bootloader once you get the opportunity.

You could potentially write a crontab script that would check for the contents of rms_mqtt file, and if its not good - change rms_mqtt config with the correct one, either by editing the file directly or via UCI commands. Though, this is a questionable workaround.

Kind Regards,

Hello, thank you for your answer.
The thing is for now I’m not able to create/change the content of the rms_mqtt file which is missing.
I installed sudo and nano by doing

opkg install sudo nano

Doing the installation of sudo, I got the message:

Configuring sudo. Collected errors: * wfopen: //usr/lib/opkg/info/sudo.prerm: No error information.

then I tried

sudo nano /etc/config/rms_mqtt

But I can’t save the content of the rms_mqtt file, I get the message “No error Information” when I try to save. I tried to uninstall and reinstall sudo but I keep getting the same issue.

Is there a workaround to this ?
Thank in advance,


I think a reason to this problem is that during the uninstallion of sudo, the remote RUT had been shutted down. I’m not able to get a proper installation of sudo now. What can I do ?


There should be no need to install sudo. If you want to open a file in text editor, simply execute:

vi /etc/config/rms_mqtt

Press i to start editing. To save changes and exit, press ESC and type :wq! (or :q! to exit without changes).

Kind Regards,


I tried to use vi without sudo, but I keep having the message:
'/etc/config/rms_mqtt' No error information
when trying to save the file and exit


Something is definetely wrong with the system/device. If it is working right now, I suggest leaving it for now. But whenever you get the opportunity, I strongly recommend to flash the firmware via bootloader.

Kind Regards,


For the RMS config, could you please try restoring the config via following commands:

rm -rf /etc/config/rms_mqtt
uci import rms_mqtt < /rom/etc/config/rms_mqtt
/etc/init.d/rms_mqtt restart

Does this work for you?

Kind Regards,

Hello, I tried your commands, but I got

uci: I/O error

when I did

uci import rms_mqtt < /rom/etc/config/rms_mqtt

This topic was automatically closed after 20 days. New replies are no longer allowed.