Data to server - stuck repeating the same data


I am setting up a modbus + data to server for the first time on a TRB255. Modbus is working (test shows data) and data to server is posting but the data is repeated rapidly forever and only one message is sent.

The server that receives the data is written by me just for testing only (later i will just a real webserver) in the local network. It is a mini httpd server that i have full control over. When receiving a POST, the content is read and a 201 (or 200) is returned with a location url (for result code=201) that i assume the TRB does not use.
TRB Firmware=TRB2_R_00.07.05.4

See attached screenshots to server received data and my modbus/dts settings. I am just testing with the StatusAndTime request.

As you can see, the TRB connects only once and then sends the same data/value rapidly (about 2x per second) and i have left it running for 2 minutes. The 72 is the content-length.
The URL parameter ORG=123 is just for testing

I suspect that the return response may not be recognized by the TRB. This is the response that is sent back. txtResponseCode and txtLocation are on the form as 201 and DTS/ExD but i have used other values as well.

Response.ResponseCode = txtResponseCode.Text;
Response.SetHeader("Location", txtLocation.Text);
Response.SetHeader("Content-Type", "application/json; charset=utf-8");

Many thanks in advance,




Thanks for reaching us

Could you please verify the time interval in the data to the server? This refers to the duration in seconds for collecting or sending data to the destination.

Would you mind restarting the router? This is necessary because the data is stored in flash memory, and it is transmitted according to the specified time intervals.

If you have any further questions, feel free to reach out to us. We’re here to help!


Thanks Mahmoud,
The interval was set to 10 but i have changed it to 60.

I tried to use the LAN port for an internet connection (bridging with WAN - another post that i will create next) and that worked for 20 seconds (and flooded the MQTT broker) but then a could not connect to the TRB. After a hard reset, the Data To Server service started working as expected.

I also found the article about deleting the modbus database with cron, like:
*/5 * * * * rm -rf /tmp/modbus_db >/dev/null 2>&1
This may have helped as well.

Thanks a lot for you assistance,

This topic was automatically closed after 15 days. New replies are no longer allowed.