Data connection state disconnected - RUTX50

I know that there are many posts about this topic, but none of them helped me out. The same issue aswith many other: Home network SIM works in other devices in home network (Telia Finland), but when I plug it in the RUTX50 - the mobile data connection stays disconnected.

  • I have installed RUTX_R_00.07.07.2_WEBUI.bin
  • I have rebooted the modem a few times, and the device multple times
  • I have used the SIM in both slots
  • Checked the APN (it is correct)
  • Called the Mobile operator to check for any blocks on the subscription wrt hot spot sharing → NO

The device used to work last year. This year it worked for a while, but suddenly it stopped working. Both Wifi networks are visible. I have a dual antenna 15 m above ground (sailboat mast) and the reception is good. I get 300 Mbits/200 Mbits with the same SIM on an iPhone. And used to get similar figures last year with the gateway.

I have not done any customization for the set up. Last year it worked perfectly just by plugging in the SIM.

Please help. I hate it that I bought a close to 1000 EUR device, which performs infinitely worse than an iPhone 6 running a mobile hotspot in a plastic bag and hauled up my boat’s mast.

You would have to think it is not the SIM (as such) but more in the config and/or antenna infrastructure?

It is very likely not the SIM. What I would need help with is How to get the Data Connection state from disconnected to connected. I can’t get a connection with the external antenna (sail boat mast top) and no connection also with the small external antennas provided by Teltonika for the gateway. I am pretty sure it is with the configuration of the gateway. But I don’t know what/where/what I should do.

Have you updated the modems’ firmware? Device & Modem are different firmwares.

Have you tried a factory reset at all?

I have done the factory reset a few times. No luck. I have not updated the modem firmware. And to be honest, i didn’t really think that a new router costing this much would need such Operations. I bought this device thinking that it would be plug and play - which it was in the beginning. Until it wasn’t and there really is easy way to fix this.

Come on Teltonika! You have to do better than this!

Have you tried to go for 4G only and/or IPv4 only?

image

Domestic SIMs are often thinner than Industrial ones, so just one little thing to try.

Stick some tape on the back of the SIM and try again. Worth a shot, as the roll, pitch and yawing, may have ‘adjusted’ the SIM contacts in the router.

Will need to try the Ipv4. I have tried all available combinations of available ”G”. No luck. I don’t think it’s the Sim, as the router shows all details correctly. The only thing that seems wrong is the “Data connection state: disconnected”.

No help with IPv4 or the other tips. Tried with all Finnish operators and for all with 5G only, 4G only and auto. Tried factory resets. The device picks up the sim details correctly (imsi, iccid, msisdn). The mobile cell info is also picked up correctly. Is there a way to reboot the modem? I don’t have the skills nor the tools to update the modem firmware. Do you know if there is a a way to contact Teltonika directly? I don’t want to pay for some extra subscription to RMS if the product has a problem. Like said, haven’t done any changes to the device. It used to work and all of a sudden just stopped.

Hello qvaka,

Sorry for the late reply.

By reading the provided information, I believe that a remote session would be the best to troubleshoot the issue and see what could be done to improve your cellular network throughput.
I have contacted you via hubspot, you will find a mail in your email by which you registered to Teltonika community, there you will need to provide some information, like your ticket ID is 6333.

I will kindly wait for your reply,
DziugasS

This topic was automatically closed after 15 days. New replies are no longer allowed.