Connect RUTX50 in Bridge Mode to TP-Link Deco Mesh

Hi all,

My Deco Mesh has been running fine with my Virgin Media Hub set to Bridge mode.

I’m now wanting to replace the Virgin Media Hub with my RUTX50. I set the RUTX50 into Bridge mode by going into Network > WAN > mob1s1a1 and changing the mode from NAT to Bridge, saved and rebooted.

Interestingly I noticed DHCP and Wifi were still functional.

If I connect my Main Deco unit to the WAN port on the RUTX50, my Deco reports “No WAN IP address obtained or internet access”.
If I connect my Deco to a LAN port I get “WAN IP address obtained but no internet”.

If I connect a laptop to a LAN port, I can access the internet just fine.

Could anyone talk me through getting the RUTX50 to work in bridge mode and to provide internet access to my Deco unit?

I’ve tried passthrough mode also, which produces the same results as bridge mode - router connected to LAN port and gets an IP address but no access to the internet.


In bridge mode, connecting any device to the WAN port of the RUTX50 won’t produce any results when expecting an internet connection. This is because, in bridge mode, the router bridges the WAN and LAN interfaces.

So, if you can access the internet by connecting a laptop to the LAN port while the RUX50 is in bridge mode, it should also work for your other router. In this case, it seems like the issue lies with the other router settings.

Best regards,


Thank you. I figured out the DNS settings weren’t getting updated on the TP-Link router. I changed to static then back to dynamic and it solved the problem. Thank you.

This topic was automatically closed after 15 days. New replies are no longer allowed.