Configuration changes to RUT240 not saving beyond reboot

I have a RUT240 that I have the MODBUS client loaded on. I am trying to configure the device, but any changes are gone after rebooting the device. I accessed the router over SSH and am greeted with the following message. “Your JFFS2-partition seems full and overlayfs is mounted read-only. Please try to remove files from /overlay/upper/… and reboot!”

As a test I attempted to change the system password on this router and that failed. When I try to change the root password by CLI I get the error “passwd: /etc/passwd: Read-only file system. Passwd: can’t update password file /etc/passwd.”

It seems the file system has no free space left and running df -h from CLI confirms this.

I’ve reset the router back to default, which does format the system back to factory default. The problem returns once I install the MODBUS client software to the router.

Please advise.


Hi, do you install any other packages or upload any other files to the flash memory (NVRAM) of the router, besides the MODBUS client? RUT240 doesn’t have a lot of non-volatile memory on its own so adding some specific additional packages which “weigh” more might fill out device memory completely.

Configuration not saving does make sense, because system has to write config changes to flash in order for changes to persist through power cycles, but because the flash memory is full, configuration changes cannot be saved properly.

Hi, and thank you for the response. The MODBUS client is the only package I’ve installed. The only other files or source of disk usage I can think of would be related to when I upgraded the firmware of the device. Could some files be left behind from the firmware install or the MODBUS client install? Otherwise where could I look to clean up files that are not needed?

It’s possible that there are some leftovers (for some reason), but if you’ve done factory reset then they should be gone. Anyway, I’d advise to try out a tool like WinSCP or MobaXterm and login to the router using them. It’ll allow you to view directories in a nice, GUI-based manner. You’ll probably have to look around in /etc/ and /root/ directories to try and find larger files.

If you’re familiar with CLI then you can search through some particular directories and find largest files in them, but I don’t really have device with similar OS near me so I can’t test the command, but you could run a command like this:
du -a / 2>/dev/null | sort -n -r | head -n 40

and see if there’s some unusually large files. Do note that directories will show up at the top, but individual files will also show up (adjust head flag value if needed), but please share the output here as I’m quite interested as to why this issue is happening at all.

Also, which firmware version are you running? That might be relevant too.

This topic was automatically closed after 15 days. New replies are no longer allowed.