Can't use internet from TRB140 upon setup


I have an existing UniFi network in my home-based office. The UniFi UDM-SE can support multiple internet inputs (WAN ports), and as I am hosting business-critical infrastructure, I want to have a 4G connection as a backup internet connection. I don’t need any help with the UniFi side of things.

I bought a TRB140 and tried to follow the quick start guide today.

I set a custom IP address for the TRB140 to as that space is reserved in the UniFi network specifically for this.

At this stage, I don’t have the TRB140 even plugged into the UniFi network. I simply have the SIM card inside the TRB140, and have it connected directly to my Apple iMac computer so I could set the TRB140 up.

I went through the wizard and at the end of it, I just got a blank page with an error message intermittently appearing saying it couldn’t connect to the modem.

Assuming this was because it had just applied the new IP address (, I navigated there instead using my web browser, but nothing loads at all. I just get an unreachable error. And the iMac computer can’t access the internet at all, despite the coverage indicator being full and the 4G light being illuminated on the TRB140.

I guess I’ve done something incorrect here… in any case, I’ve pressed the reset button and am now able to get back the web UI via

I then tried again, but this time I clicked the “skip wizard” button at the start, so the system is using default settings, I guess(?). Despite this, my iMac still can’t access the internet, even with what should be a very easy setup with default settings.

If I go into the System > Maintenance > Troubleshooting page, I am able to ping google [dot] com with no lost packets, so presumably the internet connection is working…?

(I had to type google [dot] com because your forum doesn’t allow more than two links in a post for new users)

I would like to attach the troubleshoot file, but your forum doesn’t allow new users to do so, which seems shortsighted. In any case, I have uploaded it to my Dropbox account, accessible [here]

The mobile connection status page shows the mobile connection is connected…
This is with a brand new Telstra (Australia) SIM card which has been activated so shouldn’t be having problems.

I have been able to update the firmware to TRB1_R_00.07.07.3 from the server rather than uploading a file, so that suggests to me that the TRB140 has internet access…

Could someone please explain how I should set things up?

Thank you.


Based on the troubleshooting information, it appears that your TRB140 is obtaining an IPv6 address. If you are not using IPv6 for communication, you can change it to IPv4 by following these steps:

  1. Navigate to Network → WAN.
  2. Click “Edit” next to the active interface.
  3. In the new pop-up window, change the PDP type to “IPv4”.

This adjustment should help resolve your connectivity issue.

Best regards,

Thanks for your reply, but that didn’t fix the issue.

It took me a while but eventually I figured out I needed to enable “advanced” settings at the top before the view you showed became visible.

I set protocol to Mobile, mode to NAT, and PDP type to IPv4. Auto APN was enabled.

Despite this, I still can’t get internet access on the computer that is connected directly to the TRB140 (via Ethernet cable).

So, you managed to put firmware 07.07.3 to your box, that’s good.
Can you now reset one more time to factory defaults and start from scratch?
Use the WebUI if possible.

TRB140 Device Recovery Options - Teltonika Networks Wiki

Saying this because basically you did nothing wrong and what you’re trying to achieve is very basic. Something must have gone wrong on the way and you should never need to use to get to your box…

Thanks for your reply.

I did the factory reset via System → Maintenance → Backup → Reset settings as per that link. However, it got stuck erasing the partition. After about fifteen minutes, I refreshed the page, but it then 404’d entirely.

I then used the reset button on the TRB140 itself and reset things. I then went through the wizard and set everything up again from scratch.

I was then able to access a document I had saved in Google Docs through the Mac computer connected to the TRB140. However, I was not able to access anything else, including, Speedtest, Google, Facebook, etc.

I then tried and was successful at installing Speedtest via the package manager on the TRB140. I was then able to run it and got 30mbps down/5mbps up, so that’s at least working.

I then again tried to access from the Mac computer, without success.

I have no idea why Google Docs loaded, but not Google proper, or any other website I tried…

…very odd behaviour.

Also the document I was able to load was accessed directly from an old bookmark - I haven’t accessed that particular document since 2021, on my old computer, not this computer, so I don’t think it was able to load simply due to it being in my browser’s cache. It wouldn’t have been in the cache.

Hmmm - I don’t like this sentence at all.
Modem recovery looks a bit more complicated than router recovery:

TRB 140 recovery

TRB 140 FW error after update - Crowd Support Forum | Teltonika Networks

Guys from Teltonika might be able to help out from Monday.
Handing over to @Marijus

Hello @Marijus, just wondering if you had any further advice please on getting this modem to work?

I really need this up and running preferably by mid-week if possible…

Thank you.

Hello @Dave789,

I think the issue might be that you set a custom IP address for the TRB140 to Could you please explain why you did this? I’m not quite sure of the purpose behind it. By default, the TRB140 works as a DHCP server. If there’s another DHCP server in your Ubiquiti network, it could be causing issues.

If you only need the TRB140 for redundant WAN access, you can enable passthrough mode on your TRB140’s mobile interface. This will allow it to function simply as an “internet source via an Ethernet cable”, which should make management easier.

If you still intend to use that specific Ubiquiti feature, I would recommend seeking advice from them.

Best regards,

Thanks, that got that up and running.

As I explained, nothing was working as expected/documented, so I just tried changing a lot of different settings to see if anything would work. However, as I went on to say, I was trying to get internet access to the computer I had the TRB140 plugged into, and had done multiple factory resets, so the IP address change shouldn’t have mattered. This (getting internet access on the device the TRB140 is plugged into via Ethernet) still isn’t working, but it’s now set up for WAN fail-over for my Ubiquiti network and is mounted inside my server cabinet, so I no longer care to get that (internet access to the computer connected directly to the TRB140) working.



I’m glad to hear it worked out. If you encounter any other issues, feel free to reach out again.

Best regards,