Cannot add device (and probably a credit question)

Last year, I tested a TRB140 for a project. After a couple of weeks, the project was put on hold.

Last week, I completely factory reset that TRB140. Internet connection forks fine.

Yet, I cannot make it connect to RMS again. It is still setup there and I assigned a credit.
The RMS status shows it as offline. However, the device details page shows green mobile status

Looking at “LATEST CONNECTION ATTEMPTS” I see that the TRB140 tries to connect.

Now logging into the WebGUI on the device itself, I see that the RMS connection is Enabled. But the connection state says:
“Failure (Server refused connection. The device may be blocked or unidentified)”

I tried several different methods to connect to RMS, but it seems not to work.
I tried with and without “Authentication code”, I followed the Setup Wizard and the Wiki page ( TRB140 Setup Wizard - Teltonika Networks Wiki (

FW release on the device is TRB1_R_00.07.07.1, which is also shown on RMS.

What do I need to do to register that TRB140 device on RMS again?

Do I have to remove it? If yes will I loose the asigned credits?

Is there another way to re-register the device?

Thanks for any pointer


Hello Daniel,

Will I loose the asigned credits?

No, you will not lose the assigned credit, it binds to the serial of device, so by registering it once again, it will see it and won’t consume another credit.

Is there another way to re-register the device?

Go to your router’s WebUI Services → Cloud Solutions → RMS → There you will find the button to Connect, try clicking it and see what is the result.

What status do you see when you point on status in RMS platform? Offline / Online / standby or maybe you see an error?

Try unregistering the device and registering it once again in RMS and check if the same issue persists.

If this issue persists after these steps, let me know, I will contact you privately, as we might need some private information.

Let me know how it goes,

Hello @DziugasS ,

I tried all your suggestions already. At the end, I removed the device and added it again. Now it works.
Thanks for the information.

1 Like

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.