Can’t create VPN RUT241, PORT CLOSED?

I have a problem with my RUT 241.
On the network where the RUT241 is the router, I have setup a PPTP VPN pointing to my server at (QNAP NAS) and after all, this is what i get:

  • I can connect to the vpn if I use the same network (ethernet cable);
  • I can’t connect to the vpn if I use another external internet source (like my tethering phone) and I get the error that say in shortly max connection reached or too latency. I’m sure that is not the max connection reached becouse I’m the only one and set up 20 max connections.


  • I can access on internet from the RUT241 network;
  • I can access on internet from my external internet source;
  • Port forwards already done as seen in screenshot;
  • DNS and on the server
  • Enabled VPN PPTP from router from the page services>pptp as server
  • I prefer PPTP, but I tried it with even openVPN and qbelt (qnap software). Same problem.
  • Server FW up to date
  • If I try to disable the VPN feature and leaving only the port forwarding the problem is not solved;
  • PPTP port used is the default 1723;
  • If I try to check the port status with online tools, they say its closed (1723, but even others)

I’m missing something?

Below some screen from router config pages:

Immagine 2023-07-05 112623


Since you can connect from the local network, but not over the internet, could you please check if you have a public IP address on your RUT241? What are the first 2 octets of the IP address on your WAN/mobile interface?

The PPTP configuration example is available on our wiki page here. You can take a look at it and check if you have configured everything as demonstrated in the article.

Kind Regards,

screen below.
MyIp website says: 151.18.x.x

Kind regards


Your mobile interface has an IP address that starts with 10.x.x.x, which is classified as a private IP address. So your device is undergoing Network Address Translation (NAT) by your service provider, and, as a result, your device is unreachable from the internet.

You can reach out to your service provider to inquire about the possibility of obtaining a public IP address. Usually, service providers, if able to supply a public IP address, will offer a specific Access Point Name (APN) that you need to input into your router to receive this public IP address.

On RUT241, APN can be configured in Network → Interfaces → General → Edit mob1s1a1 interface Disable auto APN and enter a custom APN given to you by your provider.

Then, your device should be able to obtain a public IP address, and then it will be accessible over the internet.

Kind Regards,

Hello, IP public obtained, on router 2.x.x.x with custom apn.

With PPTP:

  • “A Connection to the remote computer could not be established, so the port used for this connection was closed.” error.
    Can’t see the user trying to connect from the logs.

Tried with OpenVPN too:

  • Can connect, but when I try to add the network drive windows cant see the server (on From the server webinterface I can see the user connected, but the user can’t reach the samba.

Of course user is enabled for vpn (both types), user is not banned, username and pw are correct. The user can create the samba connection if is the office (LAN).

What is missing?