Bug: New RUT240 Firmware shows wrong oVPN information

Firmware RUT2_R_00.07.06.13 for RUT240 includes the following fix:

  • OpenVPN: added fixes for the insecure tls-cert-profile option usage

Now finally OpenVPN works again with Seclevel=0 set but now the WebUI shows wrong information. As shown in the screenshot, the status shows disconnected and RX and TX are always 0 but the VPN-tunnel works as you can see that I am connected though the oVPN IP Adress.

Hello,

Could this be a visual web UI bug or a cache issue. Please try deleting your browser cache and restarting your device. Are the Rx and Tx values still incorrect?

Best regards,

I restartet the router multiple times and deleted all Site Data and Cookies in my Browser. I even tried Incognito Mode in Edge Browser. Still looks the same. I always connect via VPN but the router still says that this vpn is disconnected. RX and TX still show 0 B. Everything else works fine. So its just a UI bug, but it doesn’t look very trustworthy like that.
I have another 299 RUT240 Router where I want to upgrade to newest Firmware but I will wait till the bug is fixed.
If it helps to find the bug: I upgraded from RUT2XX_R_00.01.12.3 to RUT2XX_R_00.01.14.7 to RUT2_R_00.07.06.13

hi, how did you upgraded FW with ““kepp setting””, because I have same problem with RUT950 FW 6.x to FW7.6 and requirement was upgrade FW and reboot to factory and do cfg again … but this is strange. At the moment I cant to confirm if it will work.