Auto APN selects the wrong provider

I have an RUTX50, I use a EE network sim. The Auto APN shows, but I don’t have an account with that provider. I have turned off Auto APN putting in a custom value : This is an on going problem as it happened before, then I changed from Auto APN to custom and put everywhere as the APN, because EE is an acronym for everything everywhere


Could you clarify the firmware version on the device? We’ve not had any complaints with the device selecting other carrier APN for EE, so I don’t think it’s a widespread issue.
Generally, the modem will cycle through all available APNs for a single carrier, before moving on to the more generic ones (not sure how Virgin got selected).

Best regards,

Thanks for your reply, my firmware version is RUTX_R_00.07.04.5. I believe that this is the latest version. Is it correct that if the Auto APN has selected then I should replace this with a custom entry, is ‘’ correct or is ‘everywhere’ correct. When this happened before : Network-Mobile-General-Interfaces Mob1s1a1 I deleted the configuration, it said it could not be undone. Since then I manually put ‘everywhere’ as the APN and then it seemed to correct itself. My internet speed has taken a hit from 250-270Mbs download to 125-130Mbs


I’ve mostly seen other users use everywhere as the APN, so I’d suggest using this one.
As for the speed, I doubt it is related to the APN, and is most likely only a coincidence. It could be that the router simply uses different bands tham what it used before. You could try setting the device to 4G + 5G mode, and only locking it to mid and high bands, that is:

  • For LTE leave: B1, B3, B7, B40

  • For 5G leave: n78

If the performance is worse than before, then in the 5G bands add n28. Finally, if that still does not help, I’d suggest leaving the device on auto selection, and it will decide on it’s own which bands to choose for the most stable performace.

Best regards,

Thank you for your help in this matter, I will persevere

1 Like


I am also having issues with EE on Teltonika modems. We use both RUTX11 and RUT956 modems. The auto apn will always set as Status will show disconnected until I enter a custom entry (everywhere with PAP eesecure:secure).

When connected the modem often loses connection with the network. If I put the same sim into a Sierra RV55 in the same location I don’t get any drops. It appears to also not like EE when used with a wireless logic KPN sim. Modem connects to EE for a few minutes and then drops and switches to another network where it will remain for the remainder of the connection period. (RV55 will stay on EE as signal is better)

This fault paired with the NTRIP client not reconnecting after signal loss is causing a lot of problems.

Hello @PrecisionFarming @nIXy ,
I suspect the issue could be within the MNC value for EE operator, as they use multiple MNC values, and some of them could be missing from our database. I will ask you to post the first 5 numbers of the IMSI code found in the Status → Network → Mobile (do not post the full IMSI value!). This will help me determine if this issue is caused by a missing MNC value from our database.
As for the Wireless Logic issue, I suggest setting EE as the preferred operator in Network → Mobile → Network Operators, by selecting the Connection mode as Manual-Auto and specifying the operator code (first 5 numbers of the IMSI when connected to EE).
If additional help for Wireless Logic SIMs is needed, please create a separate topic, as it’s not related to this question. Thank you.

Best regards,

Good Morning,

I have this value, 23430
Also logged into another modem using WLAPN and it is also 23430.

Thank you for the information.
This Operator code is shared between 3 operators - Virgin, EE, and BT:

Since Virgin happens to be the first in the list, I presume this is why the router first tries to connect to it. However, if it’s not able to connect, it should move onto the next APN in the list, which is everywhere. Since there will be quite a few changes to the mobile connection in v7.5 release of RutOS, let’s wait until it’s out, and if the issue is still present, I’ll check why this could be happening with our RnD team. For now, I’d simply suggest using a custom APN.

Best regards,

That’s great thanks,
Do you have any idea of a release, I have customers ask for a fix date which I currently cant give them.



While we don’t have a concrete date, it should be within the following weeks.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.