Asigning a "name" to a WiFi Client?

I have a new RUT200 (RUT2M_R_00.07.07.1) and am still learning my way around.
I would like to see a hostname in the list of associated stations:
image
I am unable to find an option in the web interface, so my next thought is to add it to /etc/ethers? Will that work?
Next I note that /etc/ethers is read-only. I this out of an excess of caution? Or should I not go down this route?
Regards, Martin

Hi,

If you need to change settings for a static DHCP client, follow these steps:

  1. Go to Status → Network → LAN and click the “Create static” button next to the client you want to modify.

  1. In the new window that appears, click the link labeled “here”.

  1. You’ll then be taken to Network → DHCP → Static Leases where you can change the hostname. Don’t forget to save your changes.

After completing these steps, the hostname should be updated. You can verify this yourself.

Best regards,

Thank you Marijus,
I think I have understood your methodology? But I’m not sure that it is working!!
This is my Static Lease info:


The MAC and IP address is correct and I provided the “Hostname”
But moving on and looking back at my Wireless Associations:
image
Rebooted, waited, rebooted - still the hostname is not showing?
Regards, M.

Hello,

The issue with the name not changing might be due to the “-” symbol in “OpenWrt-B”. By the way symbol “-” can’t be used in this “Hostname” field.

Also, please remember to save your changes.

Kind regards,

Hello again,
Still puzzled. Following your suggestion, I went through this process. First, I change the hostname on the client & saved:

image

Next, refresh the RUT200 Static Lease page:

image

Now update the Hostname field and save:

Lastly, view the WiFi associations:

image

I think that “-” are allowed in hostnames.

Regards, M.

Hello,

I was referring to the Hostname on RUTOS, not the one set by your hosts.

The hostname field should not support the “-” character at all. Can you try changing other hostnames, not just the OpenWrt one, to see if it works for you?

Kind regards,

Thank you Marijus,
Problem solved now. The solution was to change the WiFi Client configuration from Static to DHCP and THEN in the RUT200 DHCP Settings define a Static Address.
Then as the client makes its DHCP requests there is a two way conversation which includes the clients hostname.
image

Regards, M.

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.

Hello,

I’m glad it worked! If you have any other issues, please feel free to reach out.

Kind regards,