Anyone having trouble configuring mwan3 Failover on firmware 7.6.x?

I opened a support case on this yesterday but wondering if the community has experienced problems configuring the Failover (mwan3) page since upgrading to Firmware 7.6 (7.6.03 in particular). I am unable to add new Policies.

No matter what options I select on that page, I just get a “An unexpected error occurred” warning when I try to Save.

Also, the UX for selecting which interfaces should be utilized imo is very non-intuitive, and often just highlights in red with a popover bubble saying “No duplicate values allowed” but no indication of where this duplication is occurring or how to fix it.

Overall, this screen appears to be largely nonfunctional at least for me (Tested on RUTX11).

Hello @luckman212,

Indeed, there is an issue with WebUI when a second wired WAN is added to the failover rules/policies. The result is that these are not saved correctly. I have reported this issue to our RnD department and it should be fixed in the future firmware releases.

For now, you can try configuring it from CLI using UCI, for example.

Apologies for the inconvinience.

Kind Regards,

@AndzejJ Ok thanks, some pointers on how to apply the settings using uci vs hand-editing the /etc/config/mwan3 file would be really useful if you have any.

Hello @luckman212,

The configuration is pretty much the same as described on the Openwrt website for mwan3 here. Specifically, check the member/policy/rule (including interface names) sections as that’s where the changes will need to be done.

Check your current configurations via:

# I would guess it will be a ifWan interface with a name option.
uci show network

#check relevant mwan3 settings
uci show mwan3
uci show mwan.mwan_default
uci show mwan.default_rule

Then make the necessary changes to interface names and policies/rules via 'uci set'.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.