Anydesk tcp tunneling

Hi there,

I am trying to connect to my router (rut950) web interface via anydesk tcp tunneling but browser shows only empty web page with title Teltonika networks. Tried with Chrome and Edge but without success. Also I tried also with different ports than 80 and 443, but still same. But, when I connect to RutX12 webUI login page is displayed without problems.

Anyone have experience with accessing webUI using Anydesk tcp tunneling feature?



You mentioned that with RUTX12 it works fine. Could you please clarify if RUTX12 is on the same network and you are connecting to it through the same PC?

Are there any configurations differences between RUT950 and RUTX12 in regards to routes, networks, or firewall? For example, static routes, firewall rules, software flow offloading, etc.

Maybe you could try to SSH into the device over the tunnel?

Check if there are no IP blocks in System → Administration → General → Security tab.

Kind Regards,

RUTX12 is on completely different location physicaly, but with the same LAN configuration. I am accessing both of them from the same PC. SSH access works perfect on both devices and I could log using Putty. Also IP Block settings is turned off, but I checked HTML source and there was a errors appear in js console:

chunk-vendors.b6b69a3d.js:90 Uncaught SyntaxError: missing ) after argument list (at chunk-vendors.b6b69a3d.js:90:73864)
app.1fb41c53.js:1 Uncaught SyntaxError: Unexpected end of input (at app.1fb41c53.js:1:463714)

When I check “app.1fb…js” file there is missing part of the code and it ends like this:

))},handleDrop:function(t){this.preventDefault( <----

And this “chunk-vendors.b6…js” is missing “)” and it ends like this:


RUT950 is on RUT9_R_00.07.04.5

I will SSH and try to find these two files and try to fix js code and get back with additional info.

UPDATE: code is there ofcourse, but Chrome and Edge for some reason doesnt load it completely.


Are you able to access RUT950 via WebUI when you are connected to it locally?

Have you tried clearing cache in the browser?

Are both devices running the same firmware version?

I assume that you have only one tunnel active at the same time.

What is the network topology for both devices? Hows everything connected and what WAN sources are used?

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.