Upgrading Teltonika charger firmware to 1.12

Hi, I see that version 1.12 is now available on my app. However, when I try to download this, the update screen exits at 40% and the app crashes. The installer and I tried this multiple times. Any suggestions? Also is this the release that has wifi access in addition to just Bluetooth?

I had that happen on one of them. I just power cycled the unit, then it worked.

Thanks for the tip - presume I just turn the charger off at the isolation switch and then back on. Have you got wifi access now?

That’s right. Turn it off and turn it on.

I don’t use Wi-Fi, I use an ethernet cable. And I only use it for OCPP. And from what I understand that’s the only reason to use Wi-Fi or Ethernet. I don’t think they have a user interface open to the HTTP/S protocol.

Although it would be a nice idea. I’ve got friends that are looking for solutions where they could:

  1. Login in to the charge point through HTTP/S
  2. See usage statistics per user, kWh used for each user separately.
  3. Export the data.

They live in a multi apartment building and share the electricity bill.

Additionally it would be interesting to have remote access to the charge point through HTTP/S. But not as a cloud service, just normal port forwarding.

Looks like the firmware was released properly (again), upgrade now works. Very minor changes only, no wifi remote access though despite this supposedly being available.

HI @GeorgeW
what changes did you find I can’t find any yet.
Still no Wi-Fi Access, App still as mostly useless as before, very sad that a relatively good charger can have such a useless app connecting only via Bluetooth, it a real disappointment.


Please check

@FurkanAkinci.32 thank you.
hopefully it will fix the Bluetooth losing the pairing intermittently, but now the start & finish charge notifications don’t work anymore. I Tried powering down and up again and deleting and re-adding the charger to the app and still no more start / finish notifications on the app anymore. Also the front screen on the app show “Update available” but when you connect to the charger there is no update.

I have been testing this latest version and appear to have similar issues - don’t get any start/stop messages (although my BYD car app sends these no problem).

A bigger concern is that the charging schedule does not work correctly in that the actual start time is up to 3 hours after the scheduled start of 1am. Charging actually started at 04:09am, 2:44am etc. End time of 6am did work. Time set correctly, diagnostics don’t show any problems etc. The whole point of having this charger was to schedule charging during low-cost time periods - really disappointing that this is not working. I am trying some other options - controlling this from car, and/or using a different app (Charge HQ) via OCPP.

No WiFi access means that I am constantly going the garage/charger to check on the status and download diagnostics. A real pain!

PS Initially got the false update message, but this has now disappeared.

that’s a disaster our peak rate is two and a half times more expensive than off peak so now I’ll need to start it manually. @FurkanAkinci.32 can we go back to the previous firmware till these issues are fixed? :persevere: