Schedules Do Not Seem to Work

Hi all,

I have just got a single phase 7kW unit. I have been using the app to try and schedule charging overnight from the grid (at my reduced tariff), and solar during the day. The schedule doesn’t seem to work!

So, with an overnight schedule, daily from 00:01 to 05:59, the main screen reads scheduled to charge at Fri 00:01. The problem is, it was telling me this on the Friday night. I would have expected it to be Saturday 00:01. I remove Friday from the schedule, then the main screen says no schedule, waiting for solar as that is my default setting.

Any advice?


Repeat Schedule: This option lets you repeat the charging schedule every week on the days you choose. For instance, if you want your electric vehicle (EV) to charge every Monday and Wednesday, you can set it up once, and it will keep repeating every week.

One-time Schedule: If you don’t enable the “Repeat schedule” function, your charging schedule will only work for the upcoming week. After the last day in your schedule, it won’t repeat anymore, and the system will automatically turn off the “Enable schedule charging” function.

Setting the Start Time in the Past: If you accidentally set the start time of your charging schedule to a time that has already passed (for today), the system will wait until the next week to start charging on that day. For example, if today is Friday and you set the start time to earlier this morning, the charging will start next Friday at the specified time.

Disabling Schedule at Midnight: After your charging schedule has ended, the “Enable schedule charging” function will turn off automatically at midnight.

Peak Hours vs. Scheduled Charging: If you have set specific “peak hours” to avoid charging your EV due to higher electricity rates (let’s say 2 PM to 3 PM), and then you set a regular charging schedule (like 5 PM to 7 PM) on the same day, the system will follow your instructions. The EV won’t charge during the peak hours you specified but will charge during the scheduled hours you set later in the day (5 PM to 7 PM in this example).

Hi Furkan,

Thanks for the response.

This is what I have found out.

My GMT offset (timezone) was 0, but I am definitely not in England. Although the time was correct, the GMT offset was not. I have a suspicion that this may have been part of the reason that schedules were not triggering.

If you don’t have a schedule for the current day, and do have a schedule for the following day, it doesn’t seem to show a schedule at all. I was expecting that it would show that there is schedule for the next day.

When you have a schedule for the current day and something for the following day, in my case I want it set for overnight cheap rates, it seems to show a schedule on the main screen.

I’m not sure if this is expected behaviour, but it doesn’t make sense to me.

However, the charging did work when there was no schedule on the current day, but a schedule for overnight charging the following day, even though the main screen did not show that it was in schedule mode.


Hi Pat_B,

Good day!

Please set the timezone manually according to your location from settings–>Date&Time section. Currently even though the time is in sync internally the timezone is GMT 0 and hence Teltocharge cannot implement schedules as configured.


This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.