FMT100 Firmware Downgrade

Hi!
I have a bunch of FMT100 GPS trackers that I’ve buyed from GPS tracking company in Poland.
I have decided to end my cooperation with that company. All devices that I have are my own, I’ve paid for that devices.

When I tried to reconfigure the devices - configurator showed error that the device is not supported.
Newest configurator available on Teltonika website is 03.27.14.Rev.00 but firmware on my devices is 03.28.04 rev 110

How can I configure that device? I think that GPS company that sold me the devices has some “tweaked” firmware so “generic” configurator doesn’t recognize that.

How to fix that situation? As the devices are not broken I don’t wan’t to buy another trackers - I have them on my desk but I can’t configure it.

Best regards

Hello,

Your devices have a special firmware that requires a special configurator, for that kindly contact your sales manager to fix the issue or create a helpdesk ticket.

If you don’t have any contact with our Sales managers, please contact them on our official website https://teltonika-gps.com/ and click on the “Contact Us” button. When you click, please fill out the form and submit it. Note: as a topic, please choose “Vehicle telematics”. Or you can send an e-mail with the description of your situation to us: Teltonika - IoT, Internet of Things When contacting Us, please provide: IMEI/Logs/Configuration file/Intenational GSM number/Firmware version/ect , please follow these recommendations: Recommendations for filling a query description - Wiki Knowledge Base | Teltonika GPS

Best Regards,
Maynard C.

Dear Maynard

That’s wrong answer and I’ve managed to fix the device myself. Your policy to not help end users is very bad.

I - as an end user don’t have access to a Sales Manager. I’ve contacted Teltonika by email and only answer that I’ve received was that you can’t help me.

With that policy I should throw good device to trash and buy another.

But I’ve managed to fix it without your help - firstly I’ve downgraded firmware of the device using Telematics Configurator Tool. I was able to configure the device but GNSS module was not woring.

Next thing - I uploaded firmware that was made for other device and it worked. I am able to configure my FMT100’s and have working GNSS.

Thanks for nothing