FMC920 Unplug Detection

When I remove external power, I do not receive a “Unplug Val:1” SMS.

I only receive a “Unplug Val:0” SMS when external power is restored - which could be a long time later, or never (i.e. in the case where a thief removes the tracker). I never receive a Val:1 SMS.

Settings are: High Priority, Eventual Records Enable, Unplug Detection Mode Simple, with 'phone number for SMS set and SMS text as ‘Unplug’.


Good day, please check if you have connected the internal battery of FMC920.

Also make sure that you are using the latest firmware:

Best Regards
Maynard C

Hello, yes the internal battery is connected, and I am using the latest firmware and configurator.

Following external power removal, after plenty of time within which an “Unplug Val:1” SMS could be sent, the unit enters Deep Sleep, then sends to the server (GPRS) every hour in Low Power Mode (as it’s configured to do).


Kindly disable the deep sleep mode from the device and test.
Or change the deep sleep mode to GPS sleep and make some test.

Maynard C

Yes, I disabled Deep Sleep, and received an “Unplug Val:1” SMS, after removing external power.

But, surely, with Deep Sleep enabled, the unit should send an “Unplug Val:1” SMS immediately after external power is removed, and before it enters Deep Sleep, i.e. while GSM is still on?

FYI, I am using a bench power supply, with two switchable outputs, one each for external power and ignition, and a DMM to measure current via external power. So, I can see when the unit enters Deep Sleep (and other states), by how much current is flowing.


For deep sleep mode, the GNSS receiver to sleep mode and turns off GSM/GPRS module (hence it is not possible to wake up the device via SMS) The device will only wakeup if ignition or movement is detected that is why the device is not sending SMS notification to your mobile.

Best Regards
Maynard C

Even with ignition on, and removal of both external power and ignition simultaneously, the unit does not send an Unplug Val:1 SMS, i.e. even when it’s not already in Deep Sleep.

Removing external power forces the unit into Deep Sleep.

The GSM/GPRS does get turned off quickly, and the unit goes into Deep Sleep (according to the configurator, which I can see reporting the change).

Isn’t this a mistake, that the unit doesn’t fire off the SMS just before GSM/GPRS is disabled? Is this something that you should look at fixing, as a firmware issue?

Or, shouldn’t the unit wake up to send a Val:1 SMS, considering that it can wake up to send server reports in Low Power mode, i.e. if the unplug happened after the unit had entered Deep Sleep?

At the very least, I would expect to receive the Val:1 SMS (perhaps with the correct timestamp), along with the Val:0 SMS (ditto), when external power is restored (though, that would be of limited use; really it’s needed at the time of unplugging).

Also, related: the Deep Sleep ‘timeout’ setting makes no difference, here, whatever I set it to - the unit goes into Deep Sleep almost immediately. Could a timeout be made to apply for when external power is removed, before Deep Sleep state is entered? Again, something you could/should look at? (The ‘timeout’ does work as expected when external power is on and ignition is then turned off).

Hi Maynard, are you able to respond to my questions / suggestions, above? How about your product managers / developers?

I suggested that, in the case of Unplug (and possibly also for other reasons?):

  1. The unit should send SMS before it enters Deep Sleep;
  2. The unit should send SMS when it wakes up during Deep Sleep.
  3. It should be possible to set a timeout, following Unplug, before the unit enters Deep Sleep.

Do you/they agree that these would be good/logical things for the unit to do?
And/or are they possible, within current firmware structure?
If so, then are they likely to be implemented?


Hello @furry

Good day Thank you for your suggestions, if you experience any bugs or issues with our latest firmware please get in touch with your sales manager or create an HD ticket.

If you don’t have any contacts with our Sale managers, please contact with them on our official website and click on the “Contact Us” button. When you will click, please fill the form and submit it.

Thank you.

Best Regards
Maynard C