FMC920 sleep mode

My FMC920 goes into GPS Sleep as expected - GPS Module Status = GPS Sleep - but it doesn’t go into Deep Sleep with the same settings, or at least I can’t get it to. I guess that’s better than not sleeping at all but it would be nice to turm off GSM too.

What could be causing that?

Firmware 03.29.00 Rev:18. Movement Source is Ignition only and the device is sitting on my desk, not moving and seeing lots of satellites. To test I turn power on and off.

After much further testing I am certain that either the FMC920 with firmware 03.29.00 Rev:18 does not go into Deep Sleep when all the conditions are met or there is some non-obvious setting that is preventing it from so doing.

However it does go into GPS Sleep mode under the same conditions and with all settings otherwise being identical. GNSS module status is GPS Sleep.

BUT in GPS Sleep it continues to report at 5 minute intervals (Data Acquisition min period) even when Periodic Wakeup is set to 0 or 15min.

Looking at this as a programmer, which I am, I’d say there are one or more bugs in this area though I’m hoping there is a setting I have missed.

Ah, now it has stopped reporting after 20 minutes in GPS Sleep but probably because the internal battery is at 1%.

Hi @creer,

Good day! I am sharing here the conditions that should be met before the device goes to Deep Sleep Mode, can you help to recheck these settings and update if the device goes to Deep Sleep Mode.

FMC920 can enter deep sleep mode if ALL of these conditions are met:

  • FMC920 is configured in Deep Sleep mode and sleep timeout is reached;

  • Device time must be synchronized with GPS satellites. From Firmware 03.18.15 version, this condition depends on the “Records saving/sending without TS” parameter:

  • After Position Fix - FMC920 time is synchronized with GNSS satellites and GPS fix is obtained;

  • After Time Sync - FMC920 time is synchronized over NTP, NITZ, or GNSS satellites;

  • Always - FMC920 will enter sleep mode without time synchronization and GPS fix.

  • Ignition (configured ignition source) is off;

  • Movement is not detected by the accelerometer or configured movement source;

  • Min. Record Saving Period (Data Acquisition Mode settings) must be larger than Open Link Timeout parameter, so that FMC920 could close GPRS link;

  • The difference between Send Period (Data Acquisition Mode settings) and Open Link Timeout must be more than 90 seconds, so that FMC920 could close GPRS link within at least 90 seconds;

  • no SMS messages are being received;

  • Data socket(s) are closed;

  • Data sending is not in progress;

  • FOTA is not in progress.

For more information you may refer to this link: FMC920 Sleep modes - Wiki Knowledge Base | Teltonika GPS

I hope this helps.

Kind regards,
Patrick S.

Hi Patrick

Thanks for that. Setting Records saving/sending without TS to Always allowed it to go into Deep Sleep.

Or to be precise, the GNSS status is Deep Sleep but it continues to send reports at 5 minute intervals as if it were not in Deep Sleep as previously reported.


How to put a stop to that?

Hi @creer,

The device would send reports depending on the Data Acquisition Settings you set on the Configuration device. I suggest you increase the On Stop Data Acquisition to prolong the reporting of the device.

For more information, you may refer to this link: FMC920 Data acquisition settings - Wiki Knowledge Base | Teltonika GPS

I hope this helps.

Kind regards,
Patrick S.

What I want to achieve is the following -

When ignition is on, the position of the vehicle (actually a motorboat) is transmitted evey 5 mins or 100m travelled. I know the settings for that.

When ignition is off, for the first 2 hours its position is reported every 5 mins. I know the settings for that.

After 2 hours the device goes into a sleep mode and reports only once every 24 hours. As far as I can make out, that is not possible. The nearest I’ve got is to put it into Ultra Deep Sleep when it does not repoirt its position at all. Good enough.

However it wakes from UDS when the vehicle is moved as detected by the accelerometer, not when ignition is turned on. My experiments show that not much movement is required to wake it up. Can the Accelerometer Delay Settings be used to dampen this effect? The documentation is unclear.