FMC640 AUX, 3x local SIM tried, not working in Mexico

Hello All,

Hoping someone can shed some light here. I have been working with Teltonika gear for 2x years and product is great. I send to my customers, they put in local sim, not even APN and it all just works. Indonesia, South Africa, Australia, Burkina Faso, New Guinnea - no issues at all. BUT MEXICO… i have tried 3x SIM with the customer, including one from a working cell phone, and the device does not even recieve SMS - and no data. Seems like it just can’t get to the network. We tried APN changes also, and nothing. Though I would expect SMS should still get to it.

It’s the AUX variant which is for Latin america, and the bands used in the area are ones supported by the unit.

Any ideas? The sims have been domestic, and not IOT, I wonder if the carriers lock my device out due to unknown IMEI or similar. THis happens in Indonesia, where they will only work with IOT sim, and not regular phone sims.

Unit was purchased in Australia.

Solved - combination of SIM not being activated yet and other factors. Working well now, the next day.