FMB640 RS489 Modbus RTU Support

Hi, I am having difficulty configuring my FMB640 devices for reading modbus-rtu slave. I have followed this guide → Modbus slave integration with FMX125/FMX640 - Wiki Knowledge Base | Teltonika GPS unsuccessfully. I have tried the following
1.Connected to my genset and sent appropriate codec12 command. No response from the device.
2.Simulated a slave with software as shown in the example url but. No response from the devices.

Note: Normal getinfo command returns an appropriate response after ack. Using a USB modbus converter directly connected to the slave returns correct modbus data in both the 2 cases above.

My configurator screen is a bit different from what is shown in the example url see

I am not sure what is the function of START ID, STOP ID. Also parity settings are missing. Could i be using wrong configurations?

Another question that i have is if the slave is not connected on RJ45 port, What is the default behaviour? Am i supposed to get any kind of response? Thanks in advance.


Good day, regarding your testing on Modbus, please make sure that you follow the instruction on wiki also, you need to create your own MODBUS command and convert it to codec 12, the device will only send a reply once your command is correct.

For more information please create an HD ticket or contact our sales manager. If you don’t have any contacts with our Sale managers, please contact them on our official website and click on “Contact Us” button. When you click, please fill out form and submit it.

Best Regards
Maynard C

Hi Maynard,

I did follow instructions and constructed my own coded12 command. I even tried the exact command found in this wiki page → Modbus slave integration with FMX125/FMX640 - Wiki Knowledge Base | Teltonika GPS no dice.

Anyway i am stumped at this point i will look into creating a HD ticket as you suggested.