FMB130 not transmitting OBD2 data

Hello,
I have configured the FMB130 and can see the OBD2 data in I/O.
The I/O are set to Low priority but data is not transmitted to server.
All other enabled data on I/O are send.

Thanks
Carsten

Hi Carsten,

Good day, please follow the instruction in this link: How to connect OBD II Bluetooth Dongle to FMB device - Wiki Knowledge Base | Teltonika GPS (teltonika-gps.com)

Note: If you were able to connect the OBD dongle with your FMB130 make sure that the Parameters are enabled like the example below:

Best Regards

Hello,
I did set this already.
I can also see some values in the list.

But I get only this on my server:

avl ID: 239 : 0
avl ID: 240 : 0
avl ID: 21 : 3
avl ID: 200 : 0
avl ID: 69 : 1
avl ID: 181 : 1.2
avl ID: 182 : 0.7
avl ID: 66 : 12.65
avl ID: 9 : 13.451
avl ID: 6 : 10.904

Best Regards
Carsten

Hello,
if I use SMS command “obdinfo” I get the following:

Prot:7,VIN:ZFA2500000xxxxxxx,TM:150,CNT:16,ST:IDLE,P1:0x98392013,P2:0x8003B001,P3:0x4CD28011,P4:0x61A88143,MIL:0,DTC:0,ID1,Hdr:18DAF110,Phy:0

So, OBD is connected and data are available.
Why do I not get any AVL ID data to m server?

Regards
Carsten

Hi Carsten,

Good day, the configuration seems okay, can you check the raw data and use the Teltonika parser?

Or if you do not have the Teltonika parser you can use flespi to check if the ODB data is coming directly to your server, flespi panel , you can create a free account on this platform.

Best Regards,

I used flespi now and get the following:

{
ain.1 : 13.286
ain.2 : 10.776
ble.1.custom.payload.hex.1 : “3D68915E42933FDEA380F5CC6EC96D”
ble.2.custom.payload.hex.2 :“3B2C108FD6B34682C27EF6CDCF”
channel.id :1170392
engine.ignition.status :false
event.priority.enum :0
external.powersource.voltage :12.463
gnss.state.enum :1
gnss.status :true
gsm.signal.level :40
ident :“350612070750714”
movement.status :false
peer :“18.196.213.123:40561”
position.altitude :30
position.direction :0
position.hdop :0.8
position.latitude :54.433718
position.longitude :10.416317
position.pdop :1.1
position.satellites :11
position.speed :0
position.valid :true
protocol.id :14
server.timestamp :1692948426.974934
sleep.mode.enum :0
timestamp :1692948395
}

OBD Status shows:

OBD Setup has e.g. Control Module Voltage and Engine Oil Temp enabled

Hello,

Kindly check again your configuration and make sure that all parameters that you need are set to low or high priority, you should receive the parameters from the OBD dongle in the IO: FMB130 Teltonika Data Sending Parameters ID - Wiki Knowledge Base | Teltonika GPS (teltonika-gps.com)

Best Regards,
Maynard C.

Hi Maynard,

I changed priority to high and rebooted FMB130.
Now it’s working.

Thanks for your support

Carsten

1 Like

About the mentioned teltonika parser: where can I find that one?

Hi,

Teltonika data parser is available from our Helpdesk, please create a ticket or contact your sales manager.
If you don’t have any contacts with our Sale managers, please contact with them on our official website https://teltonika-gps.com/ and click on the “Contact Us” button. When you will click, please fill the form and submit it. Note: as a topic, please choose “Vehicle telematics”. Or you can send an e-mail with description of your situation to info@teltonika.lt

Regards
Maynard C.