App stuck on loading

Hi there,

Today TeltoCharge (11 kw power, 3-phase, without GSM, cable version) was installed in my house.

And straight away I encountered some issues when trying to setup in my phone (Pixel 7, Android 14).
I was able to connect to charger. On next step (where you asked to name your charger, enter the price, etc), continue button didn’t worked for me.

OK, force closed the app. Reopened it, there was my charger. I selected it and it stucks on loading (don’t know what :man_shrugging:).
Restarted the app, restarted the phone, restarted whole charger couple times - same ending.

Grabbed by backup phone (you can call it burner :grin:) - Pixel 5 with Android 13, installed the app.
Was able to update FW of charger (to 1.10.7).

I hoped it will fix issue with my main phone. Cleared the cache, data and all the other possible things. Result the same - it stucks on loading.

Where is the catch? How can I make this work on my primary phone? Is it issues with Android 14 or what?
(if it’s easier for developers, they can contact me, and we can talk in Lithuanian to debug this thing)


First and foremost, I apologize for the inconvenience you’re facing.
Given that the Pixel 7 and Android 14 are relatively new, there might be compatibility issues that we need to address. I will be communicating with our RND team to discuss potential improvements to tackle such issues.

Thank you

1 Like

Any news on this?

P.S. Yes, Android 14 is quite new, but Pixel 7 is one year old

Hello Lukas,

RnD is on the issue solving. Thank you for understanding.
My best regards

Hello Lukas,

Is the problem solved? Please inform us.
have a nice day

Yes, with the latest FW (1.10.9) now everything works fine!