Wifi client login page

I have a RUTX12 and have set up a Wifi client to connect to a hotels internet (open network) but the hotel have a splash screen for authentication which comes up if I connect a phone or laptop but does not appear when I go to a browser through the RUTX12. is there a way to make this work?

1 Like

Hello,

We will soon have a guide on our Wiki on how this can be configured, but for now I will write a short guide here.

  • Make sure your device is running RUTX_R_00.07.04.4 firmware;
  • From the Package manager (Services → Package Manager → Packages) download the package TravelMate;
  • Join the hotel WiFi network as any other wireless network;
  • In the Advanced settings of the Hotel WiFi interface, enable the option “Redirect to captive portal”;

Then, connect any of your devices to the LAN network of the RUTX12 (WiFi or wired), and once you connect, you should be redirected to the Captive portal from the hotel WiFi.
Let me know if you encounter any issues!

2 Likes

Thanks I’ll give that a try, I need to upgrade firmware first though

Upgraded to new firmware and installed Travel mate and turned on Redirect to captive portal, still not getting their splash screen. I have a Log but I am unable to upload as I am a new user

Perhaps you could try using a different LAN device to check if it also does not redirect to Hotel Captive portal?
Also, make sure that hotel WiFi is the only WAN source available during the authentication.

Hi Thank you, It has worked now, I tried on different devices and still no joy and then on the Mac I was using to configure the RUTX12 I noticed that outlook was complaining it was being redirected so closed outlook, it still did not bring up the splash instantly on safari but I opened Chrome and it did, not sure if that is coincidental but got there in the end. Thanks for your swift help.

In case anyone else stumbled upon this topic looking for help, we have a Wiki article available for TravelMate configuration: Connecting to a Hotspot WiFi for Internet Connectivity - Teltonika Networks Wiki

1 Like

Oh my god! :star_struck:

Just saw the new feature in the changelog of my RUTX11.
Asked for it many times in the old forum and waited soo long for an answer, that you are working on it.
And now it’s suddenly here. If this really works, these are exciting news for all RV-Camper out there!!

I will test it on the next trip…

Thank you very, very much @Daumantas !! :+1: :+1:

1 Like

Thanks, this is a great improvement!

1 Like

I updated to RUTX_R_00.07.04.5 and activated the switch button to ‘redirect captive portal’. However, I am still not getting the splash screen from the harbor office that provides public internet access. It is just a confirmation on the terms of agreement. It does not work on any device I tested (incl. iPad), using the RUT950 as a router/hotspot.

Directly (bypassing the RUT950), I get the splash screen and can accept it.

Could this be an interference on my safety settings of my computer? Trusted certificate etc? Any advice?

Thanks eternally - I would really need this to work!
Martin

Hello,

Make sure you do not have a custom DNS server configured on the LAN devices. Additionally, could you check if the router receives an IP address from the Hotspot WiFi? If it does not, the issue is most likely with the configuration. Please create a seperate query with the answers to avoid filling this one up. Thank you!

Best regards,