VPN Bug on 07.05.04

Hi community,

i have a bug i cant explain,

On 07.04.05 was all fine. Now on 07.05.04 i have VPN Client it shows disconnected, but i can connect over the ip to the RUTX and the devices behind the RUTX. (So its working fine but this disconnect message is strange).

I also did restored default settings, and put my config clean again on the latest firmware.

The Log shows only this warnings:

Thu Nov 30 07:15:36 2023 daemon.warn openvpn(PrJ3787)[5933]: WARNING: Compression for sending and receiving enabled. Compression has been used in the past to break encryption. Allowing compression allows attacks that break encryption. Using “–allow-compression yes” is strongly discouraged for common usage. See --compress in the manual page for more information

Thu Nov 30 08:20:12 2023 daemon.err openvpn(PrJ3787)[20043]: Options error: No client-side authentication method is specified. You must use either --cert/–key, --pkcs12, or --auth-user-pass

And this is my config:

#OpenVPN_Client
/sbin/uci set openvpn.PrJ3787=openvpn
/sbin/uci set openvpn.PrJ3787._name=‘PrJ3787’
/sbin/uci set openvpn.PrJ3787.persist_key=‘1’
/sbin/uci set openvpn.PrJ3787.port=‘1194’
/sbin/uci set openvpn.PrJ3787.type=‘client’
/sbin/uci set openvpn.PrJ3787.dev=‘tun_mdex_1’
/sbin/uci set openvpn.PrJ3787.verb=‘5’
/sbin/uci set openvpn.PrJ3787.nobind=‘1’
/sbin/uci set openvpn.PrJ3787.persist_tun=‘1’
/sbin/uci set openvpn.PrJ3787.proto=‘udp’
/sbin/uci set openvpn.PrJ3787.comp_lzo=‘yes’
/sbin/uci set openvpn.PrJ3787.allow_compression=‘yes’
/sbin/uci set openvpn.PrJ3787.remote=‘icannotellyou.de
/sbin/uci set openvpn.PrJ3787.resolv_retry=‘infinite’
/sbin/uci set openvpn.PrJ3787.keepalive=‘60 180’
/sbin/uci set openvpn.PrJ3787._auth=‘pass’
/sbin/uci set openvpn.PrJ3787.cipher=‘AES-256-CBC’
/sbin/uci set openvpn.PrJ3787.data_ciphers=‘AES-256-CBC’
/sbin/uci set openvpn.PrJ3787.data_ciphers_fallback=‘AES-256-CBC’
/sbin/uci set openvpn.PrJ3787.auth=‘sha256’
/sbin/uci set openvpn.PrJ3787.use_pkcs=‘0’
/sbin/uci set openvpn.PrJ3787.enable_external=‘0’
/sbin/uci set openvpn.PrJ3787.enable_custom=‘0’
/sbin/uci set openvpn.PrJ3787._tls_auth=‘tls-auth’
/sbin/uci set openvpn.PrJ3787.auth_key_direction=‘1’
/sbin/uci set openvpn.PrJ3787.key_direction=‘1’
/sbin/uci set openvpn.PrJ3787.enable=‘1’
/sbin/uci set openvpn.PrJ3787.client=‘1’
/sbin/uci set openvpn.PrJ3787.upload_files=‘0’
/sbin/uci add_list openvpn.PrJ3787._extra=‘tun-mtu 1500’
/sbin/uci add_list openvpn.PrJ3787._extra=‘fragment 1300’
/sbin/uci add_list openvpn.PrJ3787._extra=‘mssfix’
/sbin/uci add_list openvpn.PrJ3787._extra=‘float’
/sbin/uci add_list openvpn.PrJ3787._extra=‘nobind’
/sbin/uci add_list openvpn.PrJ3787._extra=‘reneg-sec 86400’
/sbin/uci add_list openvpn.PrJ3787._extra=‘remote-cert-tls server’
/sbin/uci add_list openvpn.PrJ3787._extra=‘tls-version-min 1.2’
/sbin/uci add_list openvpn.PrJ3787._extra=‘explicit-exit-notify 2’
/sbin/uci set openvpn.PrJ3787.ca=‘/etc/vuci-uploads/cbid.openvpn.PrJ3787.caca.crt’
/sbin/uci set openvpn.PrJ3787.tls_auth=‘/etc/vuci-uploads/cbid.openvpn.PrJ3787.tls_authtls.key’
/sbin/uci set openvpn.PrJ3787.status=‘/tmp/openvpn-status_PrJ3787.log’

This topic was automatically closed after 15 days. New replies are no longer allowed.