TRB500 works only with very strong 4G / 5G signal

Hi,

Our company has a TRB500 router and it works fine indoor (connected to indoor 4G/5G distributed antenna system), but on a location where there is less signal (2 out of 3 bars), the router keeps rebooting or the 4 and 5G lights keep flashing together.
Sometimes it has connection for some minutes, after that it starts rebooting again.
Tried another sim card but that did not help.
Entered manually APN settings for KPN (Netherlands), but that also did not help.
What can be the reason?

Hello,

Please update to the latest firmware, then in the same firmware menu check if there is an update available for the internal modem (not the device itself). If there is, please ensure a stable connection, and update the internal modem. This update addresses issues with KPN 5G network.
Let me know if that helps.

Best regards,

Hi,

How can I check if there is an update for the modem? It just lists the current version:

RG501QEUAAR12A05M4G_OCPU_BETA_20211020D_04.001.00.000

Where can I find modem firmware for download?

Regards,
Brnako.

Hello @AdeG, I have similar problems, have you found a solution?

@bradojev did you have a suggestion?

Hello,

Please post the modem firmware of your device (can be found in Status → System), as well as your operator and the 5G / LTE bands the device is connecting to. Thank you.

Best regards,

We have sent the TRB500 to Teltonika and received a new router from them.
But I haven’t tested it yet.

Let me know if it shows the same behavior.
If you’re in contact with one of our sales managers, I’d recommend inquiring about this issue via them, as we will be able to establish a private communication channel in order to troubleshoot the issue further.

Best regards,

I tested it outside the office and it works fine now.

(what still does not work is to update the IOS of an iphone via Itunes on a laptop which is connected to this router, it keeps searching the apple update server. Not sure where that is blocked. When I move the simcard to a Huawei 4g modem, then all works fine…

Hello,

Indeed, that sounds weird. Could you try updating one of the modems by following the process described here and check if the issue is still present?
Nothing is blocked from the router itself, so I suspect it may be a network issue. Try setting the MTU to 1350 by navigating to Network → Interfaces → General, edit mob1s1a1, and in the Advanced settings tab, set the Override MTU option to 1350.
Let me know if that helps!

Best regards,

Best regards,