TRB500 latest firmware removed 5G only option

In the recent firmware release (TRB5_R_00.07.05), the option to choose the network type to connect to 5G only in the web UI has been removed (in “Network>Mobile>Sim card settings”)

Is there a specific reason for this change, and if not is it possible to set this option somewhere else?
Thank you!

Just select first option and router should connect to 5G if it’s possible. For 5G there is SA and NSA (which is going together with 4G), so probably for this reason you cannot select 5G only, because then NSA won’t work and could cause the issues for the users because of misconfiguration.

previously, the only way to connect to 5G SA was to use 5G only as the “auto” preferred to connect to 5G NSA and it still seems the case (at least given the cells available where I tested it).

If that interests someone, I found a workaround by using the AT commands:
#only enable 5G cell search
gsmctl --at ‘AT+QNWPREFCFG=“mode_pref”,NR5G’
#to only enable 5G SA
gsmctl --at ‘AT+QNWPREFCFG=“nr5g_disable_mode”,2’

However, every time the modem reboots the options get overwritten by the mode selected in the web GUI.

Hi, yes this should work. But as far as I remember, preferred mode is both SA and NSA

This topic was automatically closed after 15 days. New replies are no longer allowed.