TRB245 latest firmware broken

GPS NOT working with firmware TRB2_R_00.07.05 but does work with TRB2_R_00.07.04.5.

If I install firmware TRB2_R_00.07.04.5, GPS functions. If I install TRB2_R_00.07.05 GPS DOESN’T function.

I completed firmware upgrade in BOTH scenarios with “Keep Settings” OFF and also performed factory reset.

Your firmware is DEFINATELY broken on TRB245 Hardware revision 2.

Hello,
Thank you for your valuable info, but as we have further proceeded to develop various fixes and patches which will all be on the FW 07.06.01, Could i suggest upgrading the firmware and seeing if the the GPS issue is resolved ?
Regards,
Clive Pinto

Hello,

Install firmware TRB2_R_00.07.06.1 – GPS Not Functioning

Install firmware TRB2_R_00.07.04.5 - GPS Functioning

Both firmware upgrades completed with “Keep Settings” OFF

Hardware revision I have is 0002 - is this version of hardware incompatible new firmwares?

Hello,

I’ve tested the feature extensively on TRB245 with HW revision 2, but I was able to obtain the GPS fix every time:


Could you please provide a screenshot of your GPS configuration? Additionally, make sure there are no internal modem updates available in the Firmware menu.
I will also ask you to log into the device using SSH/CLI, and run the following command:

cat $(ubus call gsm.modem0 info | jsonfilter -e '@.gps_port')

And attach a screenshot of the output after a few seconds with the content blurred (like here, don’t remove the contents completely, as their length can help us understand if actual data is being received). Make sure to perform this test after 2 or more minutes after the device boots up, GPS is enabled and antenna is positioned outside, with line of sight to the sky.

Best regards,

For GPS configuration, only setting I have when testing old and new firmware is;

Services>GPS>General - GPS Configuration = ON. With old firmware, GPS position is available but not with new.

No other settings in GPS section are changed.

I have logged in as root via CLI and command
cat $(ubus call gsm.modem0 info | jsonfilter -e ‘@.gps_port’)
provides no output at all.

Since the command provides no output, that most likely means that the GPS service is not enabled on the mobile modem itself. For troubleshooting, could you try disabling the main GPS switch, pressing Save & Apply and re-enabling it again?

If that does NOT help, could you try disabling the GPS (and other constellations) using the WebUI, then via the SSH, run the following commands:

gsmctl -A 'at+qgpsend'
gsmctl -A 'at+qgps=1'
cat $(ubus call gsm.modem0 info | jsonfilter -e '@.gps_port')

And check if there is any output then.

Hello,

I have disabled all GPS from WebUI and then connected via Putty. When executing commands, I receive an error as attached.

I am wondering if modem I have is different to what you are testing with? I have modem EC25-AU.

Hello,

In that case skip the first command. It disables the GPS, but yours seems to already be disabled.

Best regards,

Hello,

I have run all commands and receive data as shown.

Data stream stops after maybe 20 sentences and command prompt does reappear, is this correct?

Map is stall saying “This section contains no values yet” and after pressing Update Location button, popup says “No GPS Signal”.

Hello,

Could you try rebooting the gateway, then enabling the GPS using the command

gsmctl -A 'at+qgps=1'

And not running the last command and instead checking the GPS status in the WebUI? Keep in mind, that it can take a few minutes to acquire a GPS fix.

Best regards,

I have rebooted, run command as suggested and GPS status in the WebUI is still “No GPS signal” even after 15 minutes.

If I reinstall firmware TRB2_R_00.07.04.5 or older GPS works fine.

Hello,

In that case, since we cannot replicate the issue locally, I will ask you to fill out the Contact Us form here so we can continue troubleshooting the issue privately. Alternatively, if you have been in contact with our sales managers, you can also message them. Make sure to add the URL of this case to your ticket.
Thank you.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.