TRB143 Data to Server for MQTT not started after reboot


is there a way to force the Data to Server service on TRB143 to reconnect after a reboot? If I use the Data to Server service to forward messages from the internal MQTT broker, it continuous to run into a timeout until the 4G connection is established after reboot. The connection to RMS is always established and I can connect to the device and switch off and on the Data to Server service to initiate MQTT again. There is no such behaviour if I use the Data to Server to forward just GSM data. Latest firmware installed (7.05), MQTT retry set to on.

Thank you,


This may help you, since you stated that you need to turn off and on the Data to server option to make it work again. So, why not try to automate restarting the service after the device boots up :slight_smile:

You can do this by navigating to System > Maintenance > Custom Scripts and add the following:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
sleep 10
/etc/init.d/data_sender restart
exit 0

I hope this help :wink:

1 Like

Hi Sponge.Bob,

thanks a lot, I set a value “sleep 600” and it works as expected.

This topic was automatically closed after 15 days. New replies are no longer allowed.