TRB140 wrong SMS time

We have a new TRB140 and we have update it to last firmware version TRB1_R_00.07.05.2.

Yesterday we try to send 13 SMS to TRB140 and in the TEXT Message we have wrote the time. All the sms was received in real time with no problem or delay, but 9 sms was received and the TIME is correct, and 4 sms was received with TIME +1.

View the image TRB140.png:

The SIM is a italian virtual operator (1Mobile).

Do you have any suggestion?

Regards

Staff IDS
Michele

Hello,

Could you please clarify if you have received the last 4 SMS messages after one hour, or is this issue simply visual? I.e. your received the messages at 14:40:38, but it shows 15:40:38?

Kind Regards,

Good morning Andzej, the issue is “simply” visual (but not so simple).
Because the sms sent at 14:40:38 was riceived at 14:40:40 but on the interface (and on the web service) it show 15:40:38.
This is not good if we want save the message raw in SQL, because the sms’s informations are wrong.

Thanks

Hello,

Please, access the device via CLI/SSH with username ‘root’ and execute the following commands to view SMS messages:

ubus -v call gsm.modem0 read_sms '{"index":-1}'
gsmctl -S -l all

Could you please tell me if the commands return SMS messages with the correct time?

Would it be possible to test this again? Also, make sure you sync Date & Time in System → Administration → Date & Time.

Kind Regards,

Try now with 3 SMS and 1 get wrong time, but received with the others.

SMS web:

SMS SSH:

Device: TRB140
Kernel: 5.4.251
Firmware: TRB1_R_00.07.05.2
Build: d861b6e2f5
Build date: 2023-10-26 05:24:40

root@172:~# gsmctl -S -l all
Index: 0
Date: Thu Nov 9 15:56:38 2023
Sender: +393200000000
Status: read
Missing: 0
UDHL: 0
IEI type: 0
IEI length: 0
Ref ID: 0
Total parts: 1
Stored parts: 1
Parts: 1
Pdus: 0
Text: 14:56

Index: 2
Date: Thu Nov 9 14:57:19 2023
Sender: +393200000000
Status: read
Missing: 0
UDHL: 0
IEI type: 0
IEI length: 0
Ref ID: 0
Total parts: 1
Stored parts: 1
Parts: 1
Pdus: 2
Text: 14:57

Index: 1
Date: Thu Nov 9 14:57:07 2023
Sender: +393200000000
Status: read
Missing: 0
UDHL: 0
IEI type: 0
IEI length: 0
Ref ID: 0
Total parts: 1
Stored parts: 1
Parts: 1
Pdus: 1
Text: 14:56:30

System time is ok:

image

Also Date & Time

image

and NTP is active with ntp1.inrim.it and ntp2.inrim.it

root@172:~# ubus -v call gsm.modem0 read_sms ‘{“index”:-1}’
{
“messages”: [
{
“index”: 0,
“sender”: “+393200000000”,
“udhl”: 0,
“iei_tp”: 0,
“iei_len”: 0,
“ref_id”: 0,
“n_parts”: 1,
“ns_parts”: 1,
“parts”: [
1
],
“date”: “Thu Nov 9 15:56:38 2023”,
“timestamp”: 1699541798,
“text”: “14:56”,
“stat_id”: 1,
“stat_id_str”: “read”,
“missing”: false,
“n_ind”: 1,
“pdus”: [
0
]
},

Hello,

Was it working properly before?

I have tried sending ~35 SMS messages, but was unable to replicate this issue. Therefore, could you please try updating the firmware to the latest v7.05.4 with ‘keep settings’ option disabled? The device will lose configurations, so make sure you can access it locally.

Kind Regards,

Thanks Andzej, but still the “time” problem.
I have updated the firmware to TRB1_R_00.07.05.4 | 2023.11.09 but I cannot disable ‘keep settings’ because is configured on our customer and in the next weeks I cannot riconfigure it.

We’ll ignore the SMS’s date/time and we’ll use the current time.

Best regards

This topic was automatically closed after 15 days. New replies are no longer allowed.