TRB140 Output fails to react

TRB140 Output fails to react after a while
TRB140 Output fails to react on I/O juggler Input state change, whereas this Output continues to react properly to sms commands

  • The issue is solved each time after a Reboot of the TRB140, but appears again after a while (after approximately 1 day)
  • Same problem occurs on 2 different TRB140 , both using R-00.07.03.4. The issue already existed on former releases.

Hello,

Could you try updating to the latest firmware and check if the issue reproduces?
No such issue has been registered on our end.
Perhaps you have another I/O features enabled (e.g. scheduler) which could cause this behavior?
If the behavior replicates on the latest firmware, I’ll ask you to run the following command via the CLI and check if the state changes (only run after the issue replicates):

ubus call ioman.gpio.dout1 update '{"value":"1"}'

If the state changes, could you try using a different browser and checking if the issue is still there?

Best regards,

Hello
First, thank you for your reply.

The issue is still present with latest FW

CLI command:
ubus call ioman.gpio.dout1 update ‘{“value”:“1”}’
must be
ubus call ioman.gpio.dio1 update ‘{“value”:“1”}’

The state changes, also with 2 different browsers.

I have indeed an I/O scheduler via Crontabs. I read the following:

0 12 * * * uci set ioman.dio1.value=1 && uci commit ioman && /etc/init.d/ioman restart
3 12 * * * uci set ioman.dio1.value=0 && uci commit ioman && /etc/init.d/ioman restart

0 */1 * * mon,tue,wed,thu,fri,sat,sun sh /sbin/ftp_upload.sh #YqIsVsyLyk
14 12 * * 6 /sbin/rut_fota --fw_info >/dev/null 2>&1 #746c74

  • /etc/crontabs.3607 1/5 20%

Remark :
the 2 first lines of the crontabs have been programmed by myself to have a daily action ,
but the 2 last lines, I do not know what it is ? and where is it coming from ?

Awaiting for your advise. Best regards.
Luc.

Hello,
I would be grateful if you could advise on how to solve this issue !
Thank you. Luc

Hello,

Apologies, missed your reply.

The first line seems to be coming from the Services → Traffic logging section, and the second line checks the firmware releases.

As for your scripts, why not use the I/O Scheduler for this task?

Best regards,

The scheduler function does not allow for a recurrent daily 3 minutes activation of the output, as we need it (which means activation for 3 minutes every day at the same time of the day). On top of that we need also to activate the output by a sms command, which is incompatible with the scheduler (as stated by the system when we try it).
May I stress again that our solution is perfectly working, but after a while, needs a reboot of the TRB140. This is strange !
Best regards

Hello,

Perhaps you could try moving the commands to a script and calling the script from the crontabs?
It may be that the && operator is what is causing the issues here, so please try setting up the script like so:

#!/bin/sh
uci set ioman.dio1.value=1
uci commit ioman
/etc/init.d/ioman restart

And calling the crontab like so:

0 12 * * * /etc/test.sh >/dev/null 2>&1

Let me know if this helps!

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.

Hello,

I used your proposed following script:
#!/bin/sh
uci set ioman.dio1.value=1
uci commit ioman
/etc/init.d/ioman restart

It is indeed working : at value=1 the Output go High, and with value=0, the Output go Low

But after that, I am confused how to use your phrasing:
“And calling the crontab like so:
0 12 * * */etc/test.sh >/dev/null 2>&1 » ``

The Output should go High every day at 12:00 and Low at 12:03.
What should be the Crontab script ?

Thank you for your support.

Hello,

You should have two scripts - one for setting the output to HIGH, and another for setting it to LOW. This is also possible to do using one file by utilizing arguments, but for the sake of simplicity, let’s use two.
One file will have contents like so:

#!/bin/sh

uci set ioman.dio1.value=1
uci commit ioman
/etc/init.d/ioman restart

exit 0

This file can be called output_high.sh and could be stored in /etc folder.
Another file will have the following contents:

#!/bin/sh

uci set ioman.dio1.value=0
uci commit ioman
/etc/init.d/ioman restart

exit 0

This file can be called output_low.sh and could also be stored in /etc folder.
The to the crontab file add these lines:

0 12 * * * /etc/output_high.sh >/dev/null 2>&1 #set the output to high
3 12 * * * /etc/output_high.sh >/dev/null 2>&1 #set the output to low

You may also need to apply execution rights to these files using these commands:

chmod +x /etc/output_low.sh
chmod +x /etc/output_high.sh

And that should be it, the output will be set to high every day at noon for 3 minutes.

Best regards,

Thank you very much Daumantas, for your smart advice.
It is working now.
Best regards.
Luc

1 Like