TRB140 not working correctly

We have roughly 100 TRB 140’s used with a Fixed IP sim all from the same supplier. We have roughly 40 of these units working with no issues, simply activate the sim and go.

Recently we attempted to start another router and found this did not work, with sims all from the same supplier and routers configured with exactly the same config (this is applied via a backup file) and both running the latest firmware from the teltonika website.

We can take a working sim out of the router and put into this non working router and the issue still persists so we are certain the issue is not a sim. Similarly we can take the sim out of the non working router and put into another and the sim will work.

We have tried configuring APN details manually (changed from auto) this has 0 effect. We can see from the router login that it is connected to a network (02/EE/Vodafone) with data state “connected” and a wan ip address showing but we can still not connect out to google or connect into the router remotely.

We have defaulted the router in question to remove all our configuration and tried again with a default router, this also did not work.


Assuming that the configurations and firmware versions are the same, and the connection is present on some devices but not on others, I would suggest to check the following:

  • Check the firmware version of the internal modem on TRB140. This can be seen in Status → System. Do you see an patterns/discrepancies there? For instance, check if all the devices that are functioning correctly share a common firmware version while the devices experiencing issues are on a different version. Additionally, check if there is a mix of firmware versions, with some devices on the same version, yet a part of those are working and another part does not.

  • Take the IMEI numbers of the non-working devices and ask your service provider if the devices with those IMEI numbers are allowed on the network.

Also, what is your operator?

Let me know about the results.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.